Part V

Using Visio for Architecture and Engineering

IN THIS PART

Chapter 25
Working with Scaled Drawings

Chapter 26
Creating and Managing Scaled Drawings

Chapter 27
Laying Out Architectural and Engineering Plans

Chapter 28
Planning Space and Managing Facilities

Chapter 29
Integrating CAD and Visio

Chapter 30
Working with Engineering Drawings
If you’ve ever experimented with a new office layout by shoving your office furniture around, you already appreciate the value of working with scaled drawings. The objects you place in a design on paper are much easier to move around than the real-world building components, furniture, and equipment you deal with during construction. By scaling real-world objects up or down, you can work on them at a manageable size, manipulate them into the results you want, and easily share them with colleagues. In addition, by drawing real-world objects at different scales, you can show more or less detail without consuming entire forests of trees. For example, the layout of a factory floor might be scaled to $\frac{1}{8}” = 1’ 0”$, whereas the connection details between a steel column and a floor joist could be $\frac{1}{2}” = 1’ 0”$.

For technical drawings such as architectural plans, accuracy is essential or the construction crews in the field will wield their hammers getting pieces to fit together—usually with results that don’t make the client or the architect happy. To make field assembly go smoothly, the shapes on drawings must be placed precisely and accurately.

Although Visio isn’t meant to replace a computer-aided design (CAD) application, it has tools to produce precise plans. Visio includes shapes that are designed to work on scaled drawings and adjust to the scale you’re using. Many of architectural and engineering shapes in Visio include behaviors that help you lay out components on your plan, although Visio shapes can’t deliver the equivalent of a bachelor’s degree in architecture or engineering.

In this chapter, you’ll learn which Visio templates produce scaled drawings, how to use scale and units to your advantage, and how to indicate dimensions on your scaled drawings. Following chapters cover the specifics of
creating different types of scaled drawings, such as office layouts, building plans, and different
types of engineering plans.

To learn about methods for positioning shapes precisely, see Chapter 4.

Exploring Scaled Drawing Templates

Visio provides several drawing templates specifically designed to produce scaled drawings. Visio
automatically sets the units and drawing scale to those common for the type of drawing. Scaled
shapes on the associated stencils resize to the scale of the drawing as long as the drawing and
shape scales aren’t too disparate. Besides, you can specify whatever drawing scale you want on any
Visio drawing and create shapes to work at that scale.

Choosing the Right Scaled Drawing Template

If you use Visio Standard, the Office Layout template works not only for office layouts but for
building plans as well. In fact, it’s your only choice because the Office Layout template is the only
Visio Standard template with shapes for walls.

Visio Professional offers plan templates suited to different types of plans. For example, although
the Office Layout template is available, the Floor Plan template is better because it creates a stan-
dard architectural size page and opens stencils with more shapes for walls, doors, windows, and
other common building components. Most of the Maps and Floor Plan templates use an architec-
tural page size of 36 inches by 24 inches and a drawing scale of \( \frac{\frac{1}{4}}{4} = 1' \) or an A4 page using a
drawing scale of 1:50 and millimeters for metric units. In the Engineering category, the Parts and
Assembly Drawing template uses engineering page size and scale.

For a complete list of the stencils that open with templates, see Chapter 42.

Most scaled drawing templates belong to the Maps and Floor Plans category in Visio Professional.
The Parts and Assembly Drawing template is part of Visio Professional and is the only scaled draw-
ing template in the Engineering category. Here are the Visio templates available for scaled drawings:

- **Office Layout** — The Office Layout template is the only scaled drawing template avail-
able in both Visio Standard and Visio Professional. It’s useful for laying out seating plans,
tracking inventories of furniture and other office equipment, planning office space and
cubicle placement, or planning for office moves. The template sets the page to a letter-
sized landscape page and an architectural scale of \( \frac{\frac{1}{2}}{2} = 1' 0" \). The metric template sets the
paper and scale to A4 and 1:25.

- **Floor Plan** — The Floor Plan template is like the Office Layout template on steroids.
Its stencils include more shapes for building components, so you can design buildings,
facilities, and space layouts. Still, you don’t want to try to design a skyscraper with it. The

template sets the page to an ANSI Architectural size 36" × 24" and an Architectural scale

of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **Home Plan** — The Home Plan template provides shapes for laying out spaces and rooms

in houses as well as designing the interior layout of each room with furniture and fixtures. The template sets the page to an ANSI Architectural page of 36" × 24" and an Architectural scale of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **Plant Layout** — At the other end of the spectrum from home and office layouts, the Plant

Layout template is designed to help lay out large equipment on factory floors or the

spaces required for storing, receiving, and distributing inventory. The template sets the

page to an ANSI Architectural page of 36" × 24" and an Architectural scale of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **Electrical and Telecom Plan** — As its name implies, this scaled template provides shapes

for adding electrical and telecommunications services to floor plans. The template sets

the page to an ANSI Architectural page of 36" × 24" and an Architectural scale of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **Plumbing and Piping Plan** — This scaled template provides shapes for laying out

plumbing fixtures and pipes on floor plans. The template sets the page to an ANSI

Architectural page of 36" × 24" and an Architectural scale of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **Reflected Ceiling Plan** — If you’ve ever stared up at a ceiling in a commercial building,
you know that they are teeming with lights, sprinklers, and other assorted services. This

scaled template provides shapes for laying out the reflected ceiling grids and tiles as well as

the sprinklers, diffusers, and lights. The template sets the page to an ANSI Architectural

page of 36" × 24" and an Architectural scale of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **HVAC Plan** — The HVAC Plan template helps lay out the HVAC ductwork and devices

that keep spaces comfortable regardless of the temperature outside. The template sets the

page to an ANSI Architectural page of 36" × 24" and an Architectural scale of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **HVAC Control Logic Diagram Plan** — This template shows the controls for the HVAC

systems in a building. The template sets the page to an ANSI Architectural page of 36" × 24".

Because this plan doesn’t require precision placement, the scale is set to 1 to 1.

Metric uses A4 at 1:1.

■ **Security and Access Plan** — This template includes shapes for laying out devices for

access to building, such as doors and turnstiles, and security features, such as keypads,
card readers, and cameras. The template sets the page to an ANSI Architectural page of

36" × 24" and an Architectural scale of \( \frac{\frac{1}{4}}{\text{foot}} = 1' 0" \). Metric uses A4 at 1:50.

■ **Site Plan** — The Site Plan template includes shapes for landscaping, from the layout of

your backyard to the plans for a park or commercial development. Because site plans

cover a lot of ground, the template sets the page to an ANSI Architectural page of 36" × 24"

and an Engineering scale of \( \frac{1}{40} \text{foot} = 10' 0" \). Metric uses A4 at 1:200.
- **Space Plan** — Space planning is the task of designing the overall layout and relationships between spaces, such as operating rooms, supply closets, and the admitting area. The Space Plan template includes shapes for arranging spaces without the details inside them. Because space plans cover larger spaces, the template sets the page to a letter-sized landscape page but uses an Architecture scale of $\frac{1}{8}" = 1'0"$. Metric uses A4 at 1:100.

- **Parts and Assembly Drawing** — The Parts and Assembly template, which is the only scaled template in the Engineering category, provides shapes for drawing schematics or detailed mechanical drawings of parts and how they go together. The template sets the page to an n ANSI Engineering B-size page of 17" × 11" and an engineering scale of $\frac{1}{4}$:1. Metric uses A4 at 1:10.

**Working with U.S. and Metric Templates**

All Visio templates are available in both U.S. and metric units. When you install the English language version of Visio, the installation procedure checks the settings on your computer and installs the templates that match. If you use both types of units in your work, you can install both sets of templates on your computer. With both sets of templates installed, you simply choose the template with the units you want to use when you create a new drawing.

To install both sets of templates after Visio is already installed, follow these steps:

1. If Visio is running, save your work and then choose File ➤ Exit.
2. Click the Start button and choose Control Panel.
3. In the Control Panel window, double-click Add or Remove Programs.
4. In the Currently Installed Programs list, select Microsoft Office Visio and then click Change.
5. On the first wizard page, select the Add or Remove Features option and then click Continue.
6. On the Installation Options tab, click the plus sign next to Microsoft Office Visio. If options that you want to use are preceded by a red X, such as Solutions (US units), Solutions (Metric units), Add-ons (US units), and Add-ons (Metric units), click the arrow to the right of the red X and then, from the shortcut menu, choose Run from My Computer.
7. Click Continue.

When both U.S. and metric unit templates are installed, Visio displays two options for each built-in template. When you choose File ➤ New and point to the template category, you’ll see one template with (US units) after the template name (Visio doesn’t use the periods for U.S.), and the other followed by (Metric). Choose the template that uses the units you want, and Visio sets up the drawing with the appropriate measurement units and drawing scale.
When you work with both types of units, make sure when you open additional stencils that you pick the stencils whose units match the template you’re working with. Mixing U.S. units and metric units in the same drawing can make shapes line up improperly.

Setting Drawing Scale and Units

Visio scaled drawing templates automatically set up your drawings with appropriate units and scale to show real-world objects at a manageable size. As you add shapes from scaled drawing stencils to the drawing page, the shapes resize to match the drawing scale you’re using. In addition, the dynamic grid, rulers, and other Visio drawing aids obligingly adjust to the current units and scale to help you place shapes precisely. Perhaps the best aspect of working with Visio scaled drawings is that you can glue dimensioning shapes to the plan shapes on a scaled drawing. The dimensioning shapes automatically measure the distances they span and display them based on the units and drawing scale.

A shape won’t resize if its scale is more than eight times larger or smaller than the scale of the drawing page. If shapes don’t resize, make sure that you are using scaled shapes from stencils designed to work with the type of drawing you’re using. Visio compares the scale of the drawing on which the master resides to the scale of the drawing on which you drop shapes. You can create masters that work at a specific scale by setting the scale on your master drawing before you create the master shapes.

Scaling Shapes Up or Down

A drawing scale represents how a distance on a piece of paper corresponds to a distance in the real world. Whether you use architectural or engineering formats, the scale makes full-size objects shrink to fit on the drawing page. For example, the typical U.S. architectural scale of \( \frac{3}{4} " = 1' 0" \) means that 3/4 inch on a piece of paper is the equivalent of 1 foot in the real world, which works for most building plans. However, a large building might require \( \frac{1}{8} " = 1' 0" \). Conversely, you might use a scale of 1" = 1' 0" to show welds and connection details for a steel column. Site plans usually cover so much ground to capture the configuration of buildings, roads, parking lots, and more, that a scale of 1" = 10' 0" is needed.

Sometimes, scales appear in shorthand that shows only the ratio between paper size and real-world size. For example, the metric scale of 1:50 means that the drawing on paper is one-eighth of actual size. In Visio, metric scales are represented as ratios, such as 1:50, which indicates that 1 meter on paper represents 50 meters actual size.

The smaller the drawing scale, the more you can show on the same size piece of paper. Table 25-1 shows the real-world distances you can show on a 36" × 24" architectural page at different scales.
Because the drawing scale affects the size at which shapes appear on the drawing page, be sure to set the drawing scale before you add shapes to the drawing page. In addition, if you change the drawing scale after you’ve added shapes to the page, they might not resize properly. For example, the text blocks in title block shapes might not fit properly in their designated boxes.

**TABLE 25-1**

**Distances You Can Represent on Scaled Drawings**

<table>
<thead>
<tr>
<th>Drawing Scale</th>
<th>Real-World Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>1” = 10’ 0”</td>
<td>360 feet × 240 feet</td>
</tr>
<tr>
<td>1/8” = 1’ 0”</td>
<td>288 feet × 192 feet</td>
</tr>
<tr>
<td>1/4” = 1’ 0”</td>
<td>144 feet × 96 feet</td>
</tr>
<tr>
<td>1” = 1’ 0”</td>
<td>36 feet × 24 feet</td>
</tr>
<tr>
<td>1:50</td>
<td>45.72 meters × 30.48 meters</td>
</tr>
</tbody>
</table>

The shapes on scaled drawing stencils resize to match the drawing scale, as shown in Figure 25-1.

**FIGURE 25-1**

The ruler, grid, and scaled shapes all resize to match the scale of your drawing.

Two-foot column at 1/4” = 1’0” scale

Two-foot column at 1” = 1’0” scale
Setting Drawing Scale

Each drawing page in a drawing file can use a different drawing scale, which is handy when you want to lay out a floor on one page but need a larger scale drawing of a construction detail on another page. To specify the drawing scale for a drawing page, follow these steps:

1. Display the page whose drawing scale you want to set.
2. Choose File ➪ Page Setup and select the Drawing Scale tab.
3. To specify one of the scales predefined in Visio, select the Pre-defined Scale option and select one of the following types of predefined scales:
   - **Architectural** — Relates a number of inches or a fraction of an inch on paper to 1 foot in the real world
   - **Civil Engineering** — Relates 1 inch on paper to a number of feet in the real world
   - **Metric** — Relates meters on paper to a number of meters in the real world
   - **Mechanical Engineering** — Represents a ratio to scale objects up or down. For example, a mechanical engineering scale of 1/8:1 relates a fraction of a unit to one unit in the real world in order to scale objects down to fit on the page. A scale of 8:1 relates multiple units on paper to one unit in the real world in order to scale objects up so they’re legible on paper.

   **NOTE** You can also create your own drawing scale by selecting the Custom Scale option and specifying the paper distance and its corresponding real-world distance.

4. In the Scale drop-down list, choose the predefined scale you want. The values in the Page Size boxes change to indicate how many measurement units fit on the page at the scale you’ve selected.
5. Click Apply to save the drawing scale with the drawing page. Although the shapes on the drawing resize to match the new drawing scale, and the distances shown in the rulers adjust to the new scale, the real-world dimensions of the shapes on the drawing page remain the same.
6. If you use background pages with your scaled drawings, display the background page and then repeat steps 2 through 4 to apply the same drawing scale to it.

Showing Scale on Drawings

When you work with scaled drawings, it’s a good idea to indicate the drawing scale somewhere on the drawing page, so that someone viewing a hard copy of the drawing knows what the scale is and can measure objects on it correctly. Visio provides several shapes that automatically display the drawing scale for you. Table 25-2 lists some of the shapes you can use to show drawing scale.
To use one of these shapes, simply open the stencil on which the master is located and drag it onto the drawing page. By default, each shape shows the drawing scale differently, as outlined in Table 25-2 and shown in Figure 25-2. However, if you use the Drawing Scale shape from the Annotations stencil, you can change the scale type by right-clicking the shape and then, from the shortcut menu, choosing one of the scale styles.

<table>
<thead>
<tr>
<th>Shapes</th>
<th>Stencil</th>
<th>Scale Style</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing Scale</td>
<td>Annotations</td>
<td>Mechanical Engineering $\frac{1}{48}$:1</td>
</tr>
<tr>
<td>Scale Symbol</td>
<td>Annotations</td>
<td>Graphical display of scaled distances</td>
</tr>
<tr>
<td>Scale Title Block</td>
<td>Title Blocks</td>
<td>Decimal format 1:48</td>
</tr>
<tr>
<td>Title Block Large</td>
<td>Title Blocks</td>
<td>Maintains drawing scale format specified</td>
</tr>
<tr>
<td>Title Block Small</td>
<td>Title Blocks</td>
<td>Maintains drawing scale format specified</td>
</tr>
</tbody>
</table>

You can configure scale format in some shapes, whereas others have fixed scale formats.
Specifying the Units Used to Dimension Shapes

When you work with scaled drawings, two types of units are important: page units and measurement units. Page units represent the distances or units on the printer page or piece of paper you print, such as inches or millimeters. Measurement units represent real-world distances or units for the actual sizes of the objects you're drawing, and these come into play mainly when you add dimensions to a plan or when you measure a distance. For example, in the architectural scale of \( \frac{\frac{1}{4}}{1} \)", the page units are inches and the measurement units are typically feet and inches.

If you use one of the scaled drawing templates, Visio automatically sets both the drawing scale and measurement units for you. You can switch between U.S. and Metric units by choosing a U.S. units template or a Metric template when you create a new drawing. In Visio, scale and units are inextricably linked. Drawing scales specify the relationship between page distances and real-world distances, so choosing a drawing scale in Visio also sets the measurement units and page units.

Setting Default Units

Although Visio templates set units for you, it's wise to set default units to use in case you decide to create a drawing without a template. To specify either U.S. or metric units, do the following:

1. Choose Tools ➤ Options and select the Units tab.
2. Under Default Units, select the Always Offer ‘Metric’ and ‘US Units’ for New Blank Drawings and Stencils check box.
3. If you want to change the units for the current page, click Change and then choose the new units in the Measurement Units drop-down list.

The list of measurement units includes units such as days and weeks. You can choose these units if you want to produce schedules in which 1 inch represents one week or some other length of time.

Specifying Measurement Units for a Page

Similar to drawing scale, measurement units can differ for each drawing page. For example, you can specify whether the rulers and drawing grid use inches, meters, or even miles, for different drawing pages in the same drawing file. To guarantee that a plan you're drawing fits on the page, you can specify the page size in measurement units. For example, if you want to draw a building that is 60 feet long and 30 feet wide, you can set your drawing page to 70 feet by 40 feet in measurement units. To specify measurement units, use one of the following methods:

- **Specify measurement units** — Choose File ➤ Page Setup and select the Page Properties tab. From the Measurement Units drop-down list, choose the units you want and then click Apply. Visio changes the distances you see on the rulers and adjusts the grid to match the new units.
- **Specify the page size in measurement units** — Choose File ➤ Page Setup and select the Drawing Scale tab. In the Page Size (In Measurement Units) boxes, type the distances you want to represent on the page. For example, to create a page that represents 70 feet...
by 40 feet, type **70 ft.** in the first box and type **40 ft.** in the second box. Click Apply to change the page size. Visio shows the size of the drawing page and the printer paper in the preview pane, as shown in Figure 25-3.

**FIGURE 25-3**

You can change the drawing scale, the drawing page size, or the printer paper to make your plan print on the page.

---

**Dimensioning Scaled Drawings**

Measuring a hard copy of a scaled drawing to determine the actual sizes of scaled objects isn’t always possible. Only the most hard-core architects and engineers walk around with scales in their pockets. Yet, knowing the dimensions of objects on scaled drawings is crucial or the furniture you pick out at the store might not make it through the door at its destination. Typically, scaled drawings include dimensions to show sizes, offsets, and distances from reference points. Visio Professional provides stencils with shapes for dimensioning linear, radial, and angular distances.

**NOTE**

In Visio Standard, the only way you can add dimensions to a scaled drawing is with the Room Measurement shape and the Controller Dimension shape on the Walls, Doors, and Windows stencil.

Visio Professional provides two stencils with shapes specifically designed to glue to scaled shapes and show their dimensions. Although the shapes on each of these stencils share the same names...
and work the same way, they display dimensions in different formats. Depending on the type of
drawing you are creating, you can open a dimensioning stencil by choosing File ➪ Shapes ➪ Visio
Extras and then choosing either of the following stencils:

- **Dimensioning—Architectural** — For linear dimensions, architectural dimension shapes
display the dimension value above the dimension line and use slashes at the ends of the
dimension line.

- **Dimensioning—Engineering** — For linear dimensions, engineering dimension shapes
display the dimension value in the middle of the dimension line and use arrowheads at
the ends of the dimension line.

**Adding Dimensions**
Some scaled shapes, such as Room and Wall shapes, display dimensions automatically when you
select them, but the dimensions disappear as soon as the shape is no longer selected. To annotate
your drawings with dimensions that stay put, use dimension shapes instead. The Dimensioning
stencils include a wide range of dimension shapes, but they all behave similarly. You drag a dimen-
sion shape onto the drawing page and glue its dimension lines to the shapes you want to measure.
The dimension shape displays the dimension and recalculates the dimension automatically if you
resize the shape.

**Dimensioning Linear Distances**
Dimension shapes include control handles you drag to define the distance to measure as well as the
location of the dimension lines. The control handles that appear depend on the dimension shape
you choose. For example, you can add linear dimensions from a vertical baseline by following
these steps:

1. Drag the Vertical Baseline shape onto the page and position it at the bottom and to the
left of the distances you want to dimension.
2. Drag the lower green end point and glue it to a geometry point that defines the baseline
for all your dimensions, such as the corner of an exterior wall.
3. Drag the other green end point and glue it to a geometry point that defines the end of the
first distance you want to dimension, such as the closest jamb of a window.
4. To reposition the text and vertical dimension line for the first dimension, drag the yellow
control handle on the first dimension line to the left or right.
5. To define the next dimension, drag the yellow control handle between the dimension
shape's selection handles to a position above the first dimension. Another yellow control
handle appears at the end of the horizontal reference line. Drag this control handle and
glue it to a point that defines the second distance you want to dimension, as illustrated in
Figure 25-4.
6. Repeat step 5 until you have added the dimensions you want.

7. To change the spacing between the vertical dimension lines, drag the yellow control handle on the baseline of the dimension shape to the left or right.

8. To change a dimension, drag a control handle or selection handle at the end of the horizontal reference lines up or down.

**Dimensioning Radii**

Shapes for dimensioning angles include selection and control handles you can drag to configure the angular dimension. For example, you can dimension a radius with the Radius shape by following these steps:

1. Drag the Radius shape onto the drawing and glue it to a point at the center of the radius you want to dimension.

2. Drag the yellow control handle onto the arc you want to dimension.

3. To position the radial dimension text, drag the green selection handle to a new location.

**TIP**

To find out what a control handle does, position the pointer over the control handle to display a screen tip.
Dimensioning Angles

To dimension an angle, follow these steps:

1. Drag the Angle Even shape onto the drawing page and glue it to the origin of the angle you want to dimension, for example, one side of a door swing.

2. To change the angle of the line from which the angular dimension is measured, drag the selection handle on the Angle Even shape to a new location, for instance, to change the starting line from horizontal to vertical.

3. To specify the angle that you want to measure, drag the yellow control handle at the top of the Angle Even shape to the angled line, as shown in Figure 25-5.

FIGURE 25-5
Drage control handles to define an angular dimension.
You can also drag control handles on any of the Angle shapes to change the length of the extension line, the position of the angular dimension line, and the position of the dimension text.

### Specifying Precision and Units for Dimensions

The dimensions that you add to drawings show distances based on the measurement units you’ve chosen for that drawing page. Sometimes, you need more or less precision for a few dimensions on the drawing page. To change precision and units for a dimension, follow these steps:

1. Right-click a dimension shape, such as Vertical, Radius Outside, or Angle Center, and, from the shortcut menu, choose Precision & Units. The Shape Data window appears.

2. To specify the number of decimal points of precision for the dimension shape, in the Precision drop-down list, select the entry with the right number of zeroes to the right of the decimal point.

3. To specify the units you want to use, from the Units drop-down list, select the units you want. For example, a floor plan might use Feet-Inch, but for dimensions that are less than 1 foot in length, you can choose Inches.

4. In the Units Display list, select an entry to specify whether or not to show the units in dimensions.

5. To change the angle of the dimension, type an angle in the Angle box.

6. Click OK.

You can also show a shape's dimensions by inserting a geometry field in the shape's text block. To learn how to do this, see Chapter 33.

### Calculating Area and Perimeter

Visio Professional also includes tools that automatically measure the area and perimeter of any closed shape. For example, you can calculate the area within the floor of a building to determine the number of sprinkler heads you need for fire protection, or the perimeter of a parking lot to order fencing.

To measure the area and perimeter of one or more shapes, choose Tools ➤ Add-Ons ➤ Visio Extras ➤ Shape Area and Perimeter. The Shape Area and Perimeter dialog box opens, displaying the area and perimeter in the set units, such as square feet and linear feet. You can keep the Shape Area and Perimeter dialog box open as you issue other commands. If no shapes are selected, the Total Area and Total Perimeter boxes display the words No Selection. As you select shapes, their area and perimeter values appear in the boxes.

If you select more than one shape, the Total Area and Total Perimeter values reflect the values of all the individual shapes combined. For example, to measure the square footage of several separate rooms, Shift-click each room shape. The Shape Area and Perimeter values reflect the total area and total perimeter of all the rooms combined.

To calculate the area and perimeter of the boundary for several shapes, such as the footprint of a building, use the Pencil or Line tool to trace the boundary you want to measure. To calculate the area and perimeter of the boundary, select the boundary you drew.
Working with Scaled Drawings

**Summary**

Scaled drawings make it easy to create plans in which accuracy and precision are important. In Visio, you can specify drawing scales and measurement units so your plan fits on the drawing page. Visio includes shapes designed to work with scaled drawings — they resize based on the scale you’ve set for the drawing page. Each drawing page can use a different drawing scale and measurement unit, so you can show a site plan on one drawing page, a floor plan on another, and a detail of a structural connection on yet another page.

Because accuracy is important, you can add dimensions to your scaled drawings to show the real-world sizes of the objects. Visio provides two stencils for dimensions, which display dimensions in either architectural or engineering formats. Dimension shapes include control handles and selection handles you can drag to define and configure dimensions.

---

**Measuring Areas with Holes**

In many situations, you want to calculate the area for a space but want to ignore some space within it. For example, to calculate the rentable space within a building floor, you might calculate the area of the building boundary without the area for the building core, which contains stairs and elevators. You can use a Visio shape operation to help perform this calculation for you by following these steps:

1. On the Drawing toolbar, click the Line tool or Pencil tool.
2. Draw a shape around the building perimeter and then draw another shape around the building core.
3. With no other shapes selected, Shift+click the two shapes you just drew and then choose Shape ➤ Operations ➤ Combine. The Combine command creates a hole in the floor using the shape you drew around the building core.
4. Select the combined shape and choose Tools ➤ Add-Ons ➤ Visio Extras ➤ Area Shape and Perimeter. The Total Area and Total Perimeter represent the values for the entire floor minus the values for the hole.
Rather than a competitor to CAD programs, Visio makes a perfect complement to the one you use. Visio building plan templates are ideal for fast prototyping—dragging and dropping Visio shapes is a quick way to experiment with different layouts. When you settle on a few candidate plans, the Visio drawings and their shapes export easily into your CAD application. Visio is also helpful when you want to include drawings created in CAD applications in broader presentations. After inserting CAD drawings into Visio drawings, you can put Visio tools to use adding presentation annotation and graphics that CAD doesn’t handle as easily, if at all.

For folks who don’t have access to a CAD program, Visio is an adequate substitute for reviewing CAD drawings or for producing smaller plan drawings from scratch. Visio Professional stencils offer numerous shapes for a variety of building plans.

Like CAD programs, Visio provides a feature called layers to organize drawing contents. Although Visio layers differ from their CAD cousins, they control shape behavior, such as whether shapes are visible when printed or whether they are editable. For example, reference lines that you use to build a plan might be visible on the screen but invisible at printing. Or, the standard notes applied to each drawing can be locked against editing, while the layers with the building plan remain editable.

Each shape can belong to multiple layers so you can manage shapes to suit your needs. With masters on stencils already assigned to layers, Visio automatically associates shapes with the proper layers as you drag them onto your drawings. In addition, dropping shapes with layer assignments onto a page automatically creates that layer for the page.
This chapter shows how to create plan drawings by using Visio plan templates, starting with an existing CAD drawing, or by using an existing Visio scaled drawing. You will also learn ways to use layers to control the behavior of shapes, and how to assign shapes to layers as easily as possible.

Creating Scaled Drawings

More often than not, a plan is kicking around that you can use to start a new drawing. But, every once in a while, you have to create a scaled drawing from scratch. For example, you might have a CAD drawing of a basic floor plan that you want to use as the backdrop for different furniture layouts. Similarly, you could have a CAD drawing produced by someone else and want to use Visio to review and comment on it. In these cases, the solution is to insert CAD drawings into Visio drawings as backgrounds and then drag and drop Visio shapes to add the remaining information.

Conversely, if you have a Visio drawing with some plan information, such as a building shell and core, you can use that as a basis for additional plans, such as building services, by copying and pasting just the shapes you want or the entire drawing into a new plan drawing. Even better, pasting the existing Visio floor plan onto a background page means you can display it in every foreground page you create. Then, to make sure that the underlying floor plan doesn’t change, you can lock its layers so that the shapes on them can’t be edited.

Creating New Scaled Drawings

Whether you’re going to create a scaled drawing from scratch or set one up to hold an existing plan, follow these steps to prepare your Visio drawing file:

1. Create a drawing file set up for scaled plans by choosing File ➤ New ➤ Maps and Floor Plans and then choosing the template you want. Either way, the best approach is to choose a template that sets the scale to the one you plan to work with.

2. If necessary, change the default drawing scale or units, for example, to match the scale or page size of an underlying CAD drawing. See Chapter 25 for instructions on changing drawing scale, page size, and printer paper size.

NOTE: In the Page Setup dialog box, the Printer Paper list includes paper sizes for only the current printer. To choose paper sizes for a different printer or plotter, choose File ➤ Print and then select the printer or plotter you want to use. In the Print dialog box, click Close without printing. Reopen the Page Setup dialog box to select a paper size for the new printer.

Referencing Existing CAD Floor Plans

If you have an existing CAD drawing, there’s no reason to recreate it in Visio. It can act as a backdrop to additional plans constructed with Visio shapes. To insert the CAD drawing into a Visio drawing file, do the following:
1. Open the Visio drawing page into which you want to insert the CAD drawing.

2. Choose Insert ➤ CAD Drawing. By default, Visio sets the entry in the Files of Type box to AutoCAD Drawing.

3. Navigate to the folder that holds the CAD drawing you want to use, select the CAD file, and click Open. Visio does the following to set up the CAD drawing:
   - Opens the CAD Drawing Properties dialog box and fills in the settings with CAD drawing units and a custom drawing scale that fits the drawing to the page. In most cases, the settings that Visio chooses make the CAD drawing and Visio drawing play well together, so they're usually best left as they are.
   - Checks the Lock Size and Position check box, Lock Against Deletion check box, and View Extents check box so that the CAD drawing can't be moved, resized, or deleted in Visio.

4. Click OK to insert the CAD drawing on the Visio drawing page.

5. If you want to use the inserted CAD drawing as a background for Visio drawing pages, choose File ➤ Page Setup and then select the Page Properties tab. Select the Background option, type the name you want for the background page, and click OK.

Starting from an Existing Visio Scaled Drawing

Sometimes, several plans share information, such as the basic building shell for multiple building service plans or the same basic floor plan elements for several floors in a high-rise building. If you already have these shared elements in a Visio drawing, you can copy and paste them into other Visio drawing pages so you can reuse the common shapes.

When you paste shapes from a scaled drawing, Visio resizes the shapes using the drawing scale for the destination drawing page. If the drawing scales in the source and destination drawing pages are more than a factor of eight apart — for example, 1:12 and 1:200 — the pasted shapes might look very large or too small. To correct these overly swollen or shrunken shapes, change the scale of the destination drawing page to match the scale of the source page.

To copy an existing Visio plan into another drawing, follow these steps:

1. Open both the existing Visio scaled plan (the source) and the Visio drawing file into which you want to paste the reusable elements (the destination).

2. To display both drawing windows, choose Window ➤ Cascade or Window ➤ Tile.

3. Click the title bar for the source drawing window, select the shapes you want to copy, and then press Ctrl+C. If you want to copy the entire drawing page, choose Edit ➤ Copy Drawing or Ctrl+A.

4. Click the title bar for the destination drawing window and press Ctrl+V to paste the copied shapes onto the drawing page. Visio creates copies of all the selected shapes in the destination drawing.
Managing Drawing Content with Layers

If you’re familiar with CAD programs, you know that layers help you organize and manage the information on your drawings. In Visio, layers help you accomplish the following:

- View-specific categories of objects or shapes
- Print-specific categories of objects or shapes
- Display categories of objects or shapes in different colors
- Lock categories of objects or shapes to prevent editing
- Control whether you can snap or glue to shapes on a layer

For example, in a building plan, structural components could be assigned to one layer; walls, doors, and windows to another layer; furniture to a third layer; and electrical outlets to a fourth. When you work on the furniture layout, locking the other layers prevents you from moving building components inadvertently. If you want to evaluate whether the electrical outlets are sufficient, you might turn off the display of the structural and HVAC layers to focus on electrical components and their location in relation to cubicles, as illustrated in Figure 26-1.

Storing Scaled Drawing Content in One or More Drawing Files

The work on plan drawings is usually a collaborative effort, so the best approach for storing information in drawing files depends on how your team works and what you want to do. For example, if everyone wants to work on different building service plans simultaneously, you can place the data for each building service in a different Visio drawing file and link those drawings to Visio background pages in one drawing file that assembles the entire compilation of plans. (For information about linking and embedding files, see Chapter 8.)

Conversely, if you wear all the hats in the planning department, you can add all your shapes to the same drawing page and use layers to specify which shapes you see and whether they are editable. If you want more flexibility in your solo environment, you can place information on separate drawing pages, using some as background pages so they are available to several different foregrounds.

Although these techniques are more typical in a large office that uses CAD, it’s worthwhile to plan your Visio drawing files, drawing pages, and layers before you create your plan drawings.
FIGURE 26-1

Turning layer properties on and off specifies whether the shapes on a layer are visible, printable, editable, or available as reference points for snapping and gluing.

By assigning review comments to their own layer, it's easy to print the plan with or without those comments. Turning off snap and glue for specific layers helps you attach new shapes only to appropriate shapes. For example, for adding electrical outlets to a plan, you can turn off snapping and gluing to all layers except the ones for walls. Each shape in Visio can belong to one layer, multiple layers, or no layers at all. For example, you could create separate layers for different building and cubicle panels to simplify the construction of your basic building shell and office layout. But then, you could introduce another layer that shows all those shapes on one layer, so you can focus on furniture, cabling, and electrical outlets.

Many shapes in Visio stencils already contain layer assignments, so you don't have to assign the shapes to layers or think up the kinds of layers you might want and what to name them. For example, as soon as you drop a Room or Wall shape onto a floor plan, Visio automatically creates a Wall layer, (if it doesn't already exist) and assigns the Room or Wall shape to it. If you have your own vision for layering, you can create customized versions of those shape masters with the layer assignments you want.
Creating Layers

If you use shapes with layer assignments, you don't have to create layers at all. Visio automatically creates layers for the drawing page when you drop or copy a shape with a layer assignment onto the page. If the page already contains a layer with the same name, Visio adds the shape to the existing layer. However, you can also build a collection of layers manually to make sure that you have all the layers you want.

If you use shape layer assignments to create your layers, copying the wrong type of shapes onto a page might also create layers you don't want. If a drawing page contains layers you don't want, clear the visibility of all layers except the ones that you question. The shapes that are still visible are the culprits. Then, you can reassign those shapes to other layers by following the instructions in the “Removing Layers” section later in this chapter.

You must create the layers you want for each drawing page separately, because new layers are added only to the current page. New drawing pages that you add to a drawing file don't inherit the layers associated with other existing pages in the drawing file. The one bright spot in this behavior is that every page in a drawing file can have a different set of layers.

If you use the same set of layers over and over, a little preparation ahead of time can produce a reusable collection of layers. The prep work begins with creating a drawing file specifically to hold your layer collection — a template for layers. On the drawing page in the drawing file, create the layers you want by whichever method you prefer: create the layers manually or add a shape for each layer assignment you want. (When you've finished creating the layers, delete the shapes on the page.) Save the drawing file as a template, as described in Chapter 31.

Whenever you want to reuse that layer collection, you can create a new drawing file from the template or you can copy the drawing from the template into a new drawing. To copy the drawing, choose Edit  Copy Drawing. Switch to a new drawing page into which you want to copy the layers and press Ctrl+V. No shapes copy over, but the layers do.
Creating and Managing Scaled Drawings

To create a layer for a drawing page manually, follow these steps:

1. Choose View ➪ Layer Properties and then, in the Layer Properties dialog box, click New.
2. In the New Layer dialog box, type a name for the layer and then click OK. Visio creates the layer for the current page.
3. Back in the Layer Properties dialog box, in the row for the new layer, click the boxes for each property you want to apply to the layer, if they are not already selected, as shown in Figure 26-2.

**FIGURE 26-2**

In the Layer Properties dialog box, you select options to specify the behavior of each layer on a drawing page.

Renaming Layers

Suppose you want to give layers more meaningful or perhaps more concise names. You can rename existing layers for the current drawing page. The shapes on the layer remain the same. To rename a layer, choose View ➪ Layer Properties, select the layer you want to rename, and click Rename. In the Rename Layer dialog box, type a new name and click OK.

**NOTE**

Rename only the layers that you create. Although you can rename the predefined layers assigned to shapes on Visio built-in stencils, Visio creates a new layer with the original layer name as soon as you add another shape with that layer assignment. For example, if you rename the Building Envelope layer to Building Outline and then add another Exterior Wall shape, you’ll end up with a Building Envelope layer and a Building Outline layer.
Activating Layers

When you drag a shape that doesn't have a predefined layer assignment onto the page, Visio assigns it to the active layer. If no layers are active, Visio adds the shapes to the drawing page without assigning it to a layer at all. Although you can select shapes on a drawing page and assign them to a layer, it's much easier to assign shapes to a layer as you add them. To do this, activate the layer to which you want to assign the shapes by choosing View ➪ Layer Properties and then, in the row for the layer you want to make active, select its box in the Active column. Visio makes that layer active for the current page and assigns shapes without predefined layer assignments to it.

Making more than one layer active is a simple way to assign shapes to multiple layers. After setting several layers as active, simply add shapes to the page and Visio automatically assigns them to all of the active layers.

Make sure you reset the active layer as you work so that unassigned shapes you add are assigned to the correct layer. As long as you use built-in Visio shapes, an active layer isn't as important, because the shapes come with the proper layer assignments built in.

Removing Layers

Removing layers associated with a drawing page is easy. Perhaps, too easy, because removing a layer also deletes any shapes assigned to it. Before you delete a layer, be sure to reassign any shapes you want to keep to other layers first. To remove a layer, follow these steps:

1. Choose View ➪ Layer Properties.
2. Verify that the layer you want to delete shows 0 in the # column, indicating that no shapes are assigned to the layer.
3. If the layer you want to remove does have shapes assigned to it, reassign them to a different layer by following these steps:
   a. To clearly see the shapes you want to reassign, clear the Visible cells for every layer except the one you want to remove.
   b. Click OK to close the Layer Properties dialog box.
   c. Select the shapes you want to reassign and choose Format ➪ Layer.
   d. In the Layer dialog box, clear any layers that are selected and select only the layer to which you want to assign the shapes. Click OK. If all other layers are invisible, the reassigned shapes disappear from the screen.
4. Choose View ➪ Layer Properties and, in the Layer Properties dialog box, select the layer you want to delete, and then click Remove.
5. Check the Visible cell for every layer you want to see on the page.

If your layers have gotten out of hand, it’s easy to delete all unused layers. To do this, in the Layer Properties dialog box, select the Remove Unreferenced Layers check box and then click OK. Visio deletes all layers that contain no assigned shapes.
Controlling Shape Behavior with Layers

Layer properties control the behavior of shapes as a group — whether you can see shapes on the screen or when you print the drawing, whether you can edit shapes or snap and glue to them, and the color in which shapes appear. In the Layer Properties dialog box, you can specify the properties for any layer in the current drawing page. If you want the same properties for layers on other pages, you must apply those properties to each of those pages.

Although you can’t share layers between foreground drawing pages, background pages with layers achieve the same result. The layer properties you specify on the background page show up on every foreground page that uses that background. For example, you can put the basic building plan on a background page with different types of building components assigned to different layers. To hide the furniture shapes for all the foreground drawing pages in your file, you have to hide the furniture layer only on the background page.

To specify properties, choose View ➪ Layer Properties. In the Layer Properties dialog box, in the row for the layer you want to configure, select a property box to apply it. Clearing a box deactivates the property. You can control shape behavior with layers in the following ways:

- **Hide or show shapes on the screen** — Select the Visible box so that shapes assigned to the layer appear on the screen. To temporarily hide shapes on a layer, for example, to focus on specific shapes on the drawing, clear layers that aren’t important for the task at hand.

- **Hide or print shapes on the printed output** — Select the Print box to include the shapes on the layer on printouts. To prevent shapes from printing, such as construction lines when you’re printing final drawings, clear this property.

- **Assign shapes to layers automatically** — Select the Active box to set layers to active so that Visio assigns shapes to the layers automatically when you drop them on the page.

- **Prevent shapes from being edited** — When the Lock box is selected, you can’t select, move, edit, or add shapes to the layer. In addition, you can’t make the layer active.

- **Use shapes as reference for snapping** — Select the Snap box if you want to snap to shapes assigned to the layer. For example, if you are adding doors to a plan, you want to be able to snap to walls, but not to electrical outlets in the walls. When you clear a Snap box, you can’t snap to shapes on the layer. However, if you move shapes on the layer, they can snap to shapes on snappable layers.

- **Glue to shapes** — Check the Glue box if you want to glue to shapes assigned to the layer. When you clear this property, you can’t glue to shapes on the layer, although the shapes on the layer can glue to shapes on gluable layers.

**NOTE** If shapes are assigned to multiple layers and you don’t want to snap or glue to them, you must clear the Snap or Glue properties for every layer to which the shapes are assigned.
Using Visio for Architecture and Engineering

Color — Select the Color box to assign a color to the shapes on the layer. Each layer can use a different color, which overrides any color associated with graphic components of shapes on the layer, such as fill color or line color.

Although you can’t select, move, edit, or add shapes to a locked layer, you can change the color of shapes on a locked layer by setting the color in the Color column of the Layer Properties dialog box.

Assigning Color to a Layer
Assigning different colors to each layer makes it easier to identify different components in a plan, such as movable furnishings and non-movable furnishings, or new walls from existing walls. Colors can be opaque or transparent. For example, if you use filled rectangles to identify departments on a plan, you can make the layer for those rectangles transparent so that you can still see the furniture and building components. To assign a color for a layer on the current page, follow these steps:

1. Choose View ➪ Layer Properties.
2. In the Color column, select the box for the layer you want to color.
3. Click the arrow next to the Layer Color box and then select a color in the Layer Color list.
4. To change the transparency for the color, drag the Transparency slider to the value you want: 100 percent makes the layer totally invisible; 0 percent makes the layer completely opaque. To make a color visible but transparent, choose a value between 0 and 100.

Notes

Shapes assigned to multiple layers appear in their original colors.

Selecting Shapes Using Layers
Layers provide a convenient way to select groups of shapes, particularly when shapes are close together on the drawing page. To select shapes based on the layers to which they are assigned, choose Edit ➪ Select by Type, and then use one of the following methods:

- Select shapes on a specific layer — Select the Layer option and then select the check box for the layer that contains the shapes you want. To select more than one layer, Ctrl-click each layer you want to select.
- Select shapes without layer assignments — Select the Layer option and then select the (No Layer) check box.

Assigning Shapes to Layers
The simplest way to assign shapes to layers is to use shapes with built-in layer assignments. When you drop a shape with a layer assignment onto a drawing page, Visio creates the appropriate layer if it doesn’t already exist and assigns the shape to that layer. If you build your own shapes, you can assign layers to the masters, and Visio assigns them to layers automatically as well. If a shape doesn’t
have a predefined layer assignment, Visio assigns it to the active layer. The main issue with this
technique is that you must remember to change the active layer to ensure that new shapes are
assigned to the appropriate layer.

Inevitably, you end up with shapes with no assignment or incorrect assignments. For these situa-
tions, you can assign shapes to layers after you’ve added them to a drawing or assigned them to
layers.

**Assigning shapes to more than one layer makes drawings more flexible. For example,**
you can assign office furniture to both the Furniture layer as well as the Office
Equipment layer. Then, the shapes for office furniture appear whenever either of those layers is
visible.

### Assigning Selected Shapes to Layers

To assign shapes that you’ve added to a drawing page to a layer, follow these steps:

1. Select the shape or shapes you want to assign and choose Format ➪ Layer.
2. In the Layer dialog box, select the check box for the layer to which you want to assign the
   selected shapes. To select more than one layer, Ctrl-click each check box, as illustrated in
   Figure 26-3.

---

**FIGURE 26-3**

Select layer check boxes to assign shapes to one or more layers.

---

### Assigning Masters to Layers

It’s more effective to use masters with predefined layer assignments, because Visio adds them to
the correct layer automatically. You can add layer assignments to shapes you create or to built-in mas-
ters. However, because Visio built-in stencils are copyrighted as well as read-only, you should make
copies of the masters you want to change in a custom stencil or your Favorites stencil and edit
them there.
If you edit the layer assignment for a master and then drag it onto the drawing page, the new shape you create uses the new layer assignment. However, any shapes you added prior to the layer change still use the previous layer assignment. You can change the assignment for those shapes by selecting them and choosing Format ➤ Layer.

If you want to assign a Visio master to a layer or change its current layer assignment, copy the Visio master to your Favorites stencil or another custom stencil. To do this, right-click the master in the Visio stencil and then, from the shortcut menu, choose Add to My Shapes. Choose one of the custom stencils on the submenu, or choose Add to New Stencil or Add to Existing Stencil.

To assign a master to a layer or to change its layer assignment, open a Visio drawing so that the Shapes window appears, and then follow these steps:

1. Open the stencil that contains the master you want to assign to a layer. If the stencil is read-only, right-click the stencil title bar and, from the shortcut menu, choose Edit Stencil.
2. Right-click the master and, from the shortcut menu, choose Edit Master ➤ Edit Master Shape.
3. In the master drawing window, select the master.
5. Use one of the following methods to create a layer assignment:
   - To change the layer assignment, clear a layer's check box to remove an assignment and check an existing layer box to assign the master to that layer.
   - To assign a master to a new layer, click New. In the New Layer dialog box, in the Layer Name box, type the name of the new layer and click OK. Visio automatically assigns the master to the new layer. You can assign the master to additional layers by selecting other layer boxes or by clicking New and typing the name for the next layer.
6. To close the master drawing window, click the Close button for the master drawing window. When Visio prompts you to update the master, click Yes.
7. To save your changes, right-click the stencil's title bar and click Save.
8. To change the stencil to read-only, right-click the stencil title bar and choose Edit Stencil.

Assigning Groups to Layers

Groups of shapes can also have layer assignments. By default, when you select a group and choose Format ➤ Layer to assign the group to a layer, all of the shapes in the group become members of the new layer, losing their previous layer assignments. However, you can change the group assignment while retaining the shapes' current layer assignments by selecting the Preserve Group Member Layers check box in the Layer dialog box. For example, if you build groups of shapes to represent standard office configurations that include office furniture as well as computer equip-
ment, you can assign the shapes for furniture to the Furniture layer and shapes for computer equipment to the Electronics layer before grouping them. If you assign the group to the Office Equipment layer, the furniture and computer equipment could retain their previous layer assignments while also including assignments to the Office Equipment layer.

**CAUTION** If you see shapes on the drawing page, but can't select them, the layer might be locked. However, if you open the Layer Properties dialog box and find that the layer isn't locked, group layer assignments could be to blame. The problem arises when you assign individual shapes to one layer, and the group to which they belong to another layer. If the visibility of the group's layer is turned off but the visibility of the individual shape's layer is turned on, you can see the shapes because of their layer assignment, but you won't be able to select or edit them.

**Summary**

You can create blank plan drawings from Visio templates, CAD drawings, or existing Visio plan drawings. Layers help you manage the content of plan drawings by categorizing the shapes on your drawings. By specifying layer properties, you can control whether layers are visible on the screen, appear when you print your drawing, and are active or locked, and you can control both the appearance of shapes and access to shapes.
Whether you’re planning the remodel of a house, reorganizing office cubicles, or designing a major manufacturing facility, Visio floor plan templates get you started. Although Visio Standard provides only a few shapes for laying out office space, Visio Professional includes templates, stencils, and shapes for a variety of architectural and engineering plans.

Visio Professional plan templates start with the building shell — walls, doors, and windows — and continue with furnishings, electrical service, plumbing, HVAC, and other building services. The template list moves outdoors to include site and landscaping plans, security and access plans, and maps.

Unlike CAD programs, which come with oodles of drafting commands for drawing plan contents, Visio architectural and engineering capabilities stem from the shapes on the many architectural and engineering stencils. If you’re familiar with basic Visio techniques including dragging control handles and setting shape data values to implement special behaviors, you already know most of what you need. Although Visio plan templates provide the tools you need to draw plans, they don’t confer the specialized skills you need to determine what plans should contain or what constitutes an effective layout. You’ll have to read other books to learn about that.

Many of the techniques described in this chapter work equally well for the basic office plans that Visio Standard supports and the more specialized architectural and engineering plans available only in Visio Professional. This chapter talks about content specific to Visio Professional.

To learn about the different types of Visio plan templates and how to work with Visio plan drawings, see Chapters 25 and 26.
Working with Walls

In most cases, the first step in constructing a plan is placing walls to define the outside of a building to contain the stuff on the inside. Visio wall shapes represent different types of walls—structural exterior walls, interior walls, curtain walls that merely fill in the space between structural elements, and window walls. The Walls, Shell, and Structure stencil and the Walls, Doors, and Windows stencil both include built-in wall shapes with special behaviors for easily connecting walls and shape data for specifying attributes such as wall thickness and fire rating. You can also create custom wall shapes, for example, to show walls to be demolished with a hatched fill pattern.

If you began your design by creating a space plan in Visio, the easiest way to build walls is by converting Space shapes into Wall shapes. Otherwise, all the standard techniques for working with shapes (described in Chapters 4 and 5) apply to Wall shapes, too: dragging, dropping, snapping, gluing, and using the Connector tool. This section describes how to convert Space shapes into Wall shapes and provides tips for connecting walls using familiar techniques.

Converting Spaces into Walls

The Convert to Walls command makes quick work of turning the spaces in a space plan into walls that enclose those spaces. The command enables you to specify the type of wall you want to use, whether to display dimension lines, and whether to add guides to the walls it creates. In addition, you can delete the original Space shapes or keep them. For example, Space shapes come in handy when you want to show the square footage of spaces on the drawing or for tracking space in the building.

To learn more about Space shapes and other methods for laying out spaces and rooms, see Chapter 28.

To convert Space shapes into walls, follow these steps:

1. Initiate the Convert to Walls command using one of these methods:
   - Convert a single shape — Right-click the shape and, from the shortcut menu, choose Convert to Walls.
   - Convert several shapes — Select the shapes you want to convert using any selection method and then choose Plan ➤ Convert to Walls.
2. In the Convert to Walls dialog box, in the Wall Shape list, select the type of Wall shape you want to use.

TIP The Wall Shape list might seem sparse, because it includes only the Wall shapes available on open stencils. If you don’t see the Wall shape you want, click Cancel, open the stencil that contains the Wall shape you want, and begin again with step 1.

3. To automatically add dimensions to each segment of a wall that is created, select the Add Dimensions check box.

NOTE Visio can be inconsistent with its automatic dimensioning, adding redundant dimensions in some places and leaving some wall segments undimensioned. If you don’t like the dimensions that Visio adds, press Ctrl+Z to undo the results of Convert to Walls, and then rerun it with the Add Dimensions check box cleared.

4. To glue guides to each vertical and horizontal wall segment, select the Add Guides check box. Guides reduce frustration and time when you reposition wall segments. You can drag the guides to move wall segments while maintaining their connection to other walls.

5. To keep the Space shapes along with the converted Wall shapes, select the Retain option, which is ideal when you want to use spaces to track billable space.

NOTE Although the Convert to Space Shape option might sound like it turns walls back into spaces, it applies only when you convert shapes other than Space shapes (for example, lines and closed shapes you draw with the Visio drawing tools) into walls. By choosing this option, the Convert to Walls command converts the selected shapes into Wall shapes and also creates a Space shape on the interior surface of the converted walls. It also deletes the original shapes, because you now have both Wall and Space shapes.

6. Click OK to convert the Space shapes into Wall shapes and add any additional elements you specified, as illustrated in Figure 27-1. Visio creates a separate Wall shape for each wall segment in the building. Because the Wall shapes are glued together, the intersections between Wall shapes are cleaned up.

7. If you added guides to the converted walls, you can reposition a Wall shape by dragging the guide glued to it. The advantage to this method is that Wall shapes glued to the guide resize without detaching from adjacent walls. One failing is that the original Space shapes don’t resize with the walls. Fortunately, resizing a Space shape to match the new wall configuration is as simple as right-clicking the Space shape and, from the shortcut menu, choosing Auto Size.
FIGURE 27-1
The Convert to Walls command converts Space shapes or drawn geometry into Wall shapes, with optional dimensions and guides.

Creating Walls
When you add walls from scratch, standard techniques such as dragging, dropping, connecting, and gluing are about the only tools you need, and you can choose the easiest technique for the job at hand. For example, using the Connector tool with the Exterior Wall shape is the fastest way to create the exterior wall segments for a building shell. On the other hand, with short runs of interior walls, dragging and dropping Wall shapes might be more effective. As you add Wall shapes to the page and glue them together, Visio automatically cleans up the intersections so lines appear only for wall surfaces, as shown in Figure 27-2.
Although wall segments are rectangles, Visio cleans up wall intersections when you glue Wall shapes together.

For Wall shapes to connect properly and clean up after themselves, snap and glue must both be turned on. Choose Tools ➪ Snap & Glue. In the Snap & Glue dialog box, under the Currently Active heading, make sure that both the Snap check box and the Glue check box are selected. In addition, under both the Snap To and Glue To headings, make sure that the Connection Points and Shape Geometry check boxes are selected.

To create new walls on a drawing, use one of the following methods:

- **Drag and drop Wall shapes** — To add walls one at a time, drag the Wall shape you want onto the drawing page. To glue the new Wall shape to Wall shapes already on the page, glue its end points to connection points or shape geometry on existing Wall shapes. For example, you can create a wall divider by gluing a vertical Wall shape anywhere along the length of a horizontal wall. When you drag an end point to a connection point or shape geometry, Visio indicates the pending glue with a red square.

- **Use the Connector tool** — To add a sequence of connected walls, follow these steps:
  a. On the Standard toolbar, click the Connector tool.
  b. In a stencil, click the wall you want to add.
  c. For the first wall, drag between two points to define the beginning and end of the Wall shape. As soon as you complete this Wall shape, the pointer changes to the four-headed arrow, indicating that you can move the current point to a new location.
  d. To add another Wall shape that starts where the first Wall shape ends, move the pointer away from the end point and then move it back, but not quite over the end point, until the pointer changes to the Connector icon (a plus sign with a small connector next to it).
e. Drag from the current point to the end of the next Wall shape.

f. Repeat steps d and e to create additional wall segments.

When you add Exterior Wall shapes to a plan, you want the selection handles on the interior surface of the building wall, so they are lined up at the inside corners and, thus, are easy to find when you’re ready to glue other Wall shapes. If an Exterior Wall shape’s selection handles are on the edge that represents the exterior of the building, right-click the shape and, from the shortcut menu, choose Flip Wall on Reference Line.

Connecting and Resizing Walls

Visio cleans up corners and other intersections when walls are glued together, but this convenience goes only so far. If you drag a Wall shape to another position, it separates from its friends and the corners fill in again. Most of the time, what you want Visio to do when you drag walls is to keep the walls glued together and lengthen or shorten wall segments as necessary. Guides attached to Wall shapes do just that. It’s easy to glue Wall shapes to guides as you construct your plan using one of the following methods:

- **Gluing to existing guides** — In many cases, you begin a floor plan by dragging guides onto the drawing page as reference lines. If you drag a Wall shape onto a page and drag its end points to guides, Visio glues the shape to the guide automatically.

- **Creating guides with the Convert to Walls command** — If you convert Space shapes to Wall shapes as discussed in the section “Converting Spaces into Walls,” the Convert to Walls command can automatically create and glue guides to the Wall shapes created during the conversion.

- **Right-clicking a wall shape** — To add a guide to an individual Wall shape, right-click the shape and then, from the shortcut menu, choose Add a Guide.

When you drag a guide that is glued to a Wall shape, the Wall shape moves with the guide, and any Wall shapes that adjoin that Wall shape stretch or contract.

Modifying Wall Properties and Appearance

Length and thickness are obvious wall properties because they are visible on a drawing. But, shape data associated with Wall shapes controls every wall dimension: length, thickness, and height. Wall shapes include other shape data fields, as well as options for changing the appearance of walls on a plan.

Changing Wall Thickness and Other Properties

Some shape data fields for Wall shapes modify the configuration of the wall itself, whereas others store data for reference or reports. Here are the shape data fields for walls and what they do:

- **Wall Length** — Changes the length of the wall segment, regardless of the angle the segment is rotated.

- **Wall Thickness** — Changes the thickness of the wall segment, that is, from one wall surface to the other.
Laying Out Architectural and Engineering Plans

- **Wall Height** — Sets the height of the wall, which doesn’t change the visible outline of the shape. However, you can produce legends, quantity take-offs, or bills of material based on these values.
- **Wall Justification** — Controls the alignment of the Wall shape. Centered draws the wall thickness equally on either side of the points you use to create the wall. Edge aligns the wall to the selection handles.
- **Wall Segment** — By default, this field is set to Straight for a perfectly straight segment. If you change this field to Curved, Visio adds a control point to the wall so you can modify the curvature of the segment.
- **Base Elevation** — Defines the elevation of the bottom of the wall.
- **Fire Rating** — Specifies the fire rating for the wall, which is useful in materials reports.

To change shape data, right-click a Wall shape and, from the shortcut menu, choose Properties. In the Shape Data dialog box, type or select values for the fields and click OK when you’re done.

**NOTE**
If you modify shape data frequently, it’s easier to dock the Shape Data window by choosing View ➔ Shape Data Window. When you select a shape, its values appear in the fields. To change or enter a value, select the field you want to edit and type or select a value.

**Changing the Way Walls Appear**
By default, Visio shows walls as double lines — one line for each wall surface — although you might have to zoom in to see them. In Visio Professional, you can display walls in different ways. For example, to streamline a crowded drawing, you can display walls as single lines, or show walls as double lines with a reference so that the centerline of the wall is easy to spot. To change how Visio displays walls, right-click any Wall shape on a drawing page and, from the shortcut menu, choose Set Display Options. Make sure the Walls tab is selected and then select Double Line, Double Line And Reference Line, or Single Line.

**NOTE**
Changing the display options for walls affects all the Wall shapes on the current drawing page but not Wall shapes on other pages in the file.

**Changing Wall Color and Line Style**
In addition to the number of lines that represent walls, changing colors and line styles for Wall shapes is a common adjustment. For example, architects typically use different colors or fill patterns to identify existing walls, new walls, or walls to be demolished. If you simply want to make walls stand out, use the new Theme feature (on the Formatting toolbar, click Theme).

But, to show walls with specific colors that don’t change with the selected theme colors, modify the styles associated with the wall. Wall shapes use the Wall line and fill styles, so you can change color, line style, and fill pattern, by modifying the Wall styles. In fact, to show different types of walls, you’ll probably want to create a few new styles, for example, for walls targeted for demolition. To learn how to modify and create styles, see the section “Formatting with Styles” in Chapter 7.
Adding Doors, Windows, and Other Openings

Even jail cells have doors to enter or exit, so doors, windows, and other wall openings are essential. Glue and shape behaviors make it easy to add openings to walls. For example, when you add a door or window to a Visio Wall shape, the door or window automatically performs the following feats:

- Rotates to match the angle of the Wall shape
- Glues itself to the Wall shape
- Adjusts its width to that of the Wall shape
- Cleans up the Wall shape where the opening is located

Changing the configuration of a shape for openings is just as easy, whether you want a door to open to the inside or outside or swing to the left or right.

These configuration features are available whether you use shapes from the Walls, Doors, and Windows stencil in Visio Standard and Professional or the Walls, Shell, and Structure stencil only in Visio Professional.

Adding Openings to Walls

To insert a door, window, or other type of opening into a wall, simply drop an opening shape from a stencil onto a Wall shape. The shape rotates into position in the Wall shape, glues itself to the Wall shape, and changes its thickness to match the Wall shape, as shown in Figure 27-3.

By positioning the pointer on a wall edge, you can change the side on which a door opens.

If an opening doesn’t rotate to match the direction of the Wall shape, the shapes aren’t glued together. Drag the shape over the Wall shape until you see the red square indicating pending glue, at which point the shape should be rotated to match the Wall shape. Release the mouse button to add the opening to the wall.
Shapes for openings automatically adjust to match the wall thickness and orientation. Control handles help you change shape configuration.

Modifying Doors, Windows, and Openings

Shapes for doors, windows, and other openings are teeming with shape data and shortcut menu commands for configuration. For example, the direction that a door swings (in or out) or the widths of openings are editable as is the appearance of doors, windows, and openings on each drawing page. Use one or more of the following methods to change door, window, and opening shapes:

- **Reverse direction** — Right-click a Door, Window, or Opening shape, and then, from the shortcut menu, choose Reverse In/Out Opening. Or, drag the red circle control handle from one side of the wall to the other.

- **Reverse swing** — Right-click a Door, Window, or Opening shape, and then choose Reverse Left/Right Opening.

- **Reposition opening** — Drag the shape to a new position in the Wall shape. Visio heals the opening in the Wall shape at the original position and cleans up the Wall shape at the new location.
Modify dimensions and other attributes — Open the Shape Data window (choose View ➪ Shape Data Window) and then select the shape whose data you want to change. In the Shape Data Window, type or select new field values. For example, with the Double-Door shape, you can specify the width of the door, its height, the type of door, the percentage that the door is open on the page, its number, its fire rating, and its base elevation.

If you track building components in a database, you can import that data into shape data, as described in Chapter 10.

Change the door and window components that appear — Depending on the density of components, you might want to show every last detail of doors and windows or just the general outline of openings. For example, Visio displays the window frame and sash by default, but you can also show the header and sill. To change the components you see, do the following:

a. Right-click any Door or Window shape on a drawing page and, from the shortcut menu, choose Set Display Options.

b. On the Doors or Windows tab, select the check boxes for the components you want to see and then click OK. Changing the display options for Door or Window shapes affects the shapes only on the current drawing page, so you must repeat this step for each drawing page you want to change.

Set default configurations — When you use standard sizes, you can specify default properties for doors and windows. For example, you can set the width of the door frame to three feet so that every Door shape you add uses those dimensions. To do so, right-click a Door or Window shape and, from the shortcut menu, choose Set Display Options (available only in Visio Professional). On the Doors or Windows tab, click Properties. In the Set Door Component Properties or Set Window Component Properties dialog box, specify the default properties you want and then click OK. These settings affect only the current drawing page, so you must redefine these defaults for every page to which you want to apply them.

Creating Door and Window Schedules

For construction projects, door and window schedules identify each door and window in a set of construction plans and specify their dimensions and other attributes, so that the right components are installed in the right places. In Visio Professional, you can use reports to create door and window schedules that automatically collate information about the Door and Window shapes on your drawing. For example, the default Door Schedule report shows door number, door size, door type, and thickness. The default Window Schedule report includes window number, size, and type.

The easiest way to produce a door or window schedule is to drag a Door Schedule or Window Schedule shape from the Walls, Shell and Structure stencil onto the drawing page. These tabular shapes use the existing schedule report definition. If you want to show other shape data or customize the report, you can modify the report settings, as described in Chapter 10.
Adding Cubicles and Furniture

In Visio Standard, the Office Layout template is the only plan template available, but it includes the most frequently used shapes, including basic building components, office furniture, office equipment, office accessories, and cubicles. If you use Visio Professional, you can create more detailed floor plans with the Floor Plan template and choose from a broader range of shapes from the Cubicles, Office Accessories, Office Equipment, and Office Furniture stencils. There are two ways to add cubicles and furniture to plans: using predefined shapes that include the cubicles and their contents or adding each component individually. This section describes both methods.

Laying Out Office Cubicles

The Cubicles stencil has shapes that contain preassembled sets of cubicle walls, furniture, and equipment. As long as these ready-made Workstation shapes have the components you want, it's easy to lay out an office simply by dragging shapes onto the drawing page. You can build custom workstation shapes to conform to your organization's cubicle and office standards. See Chapters 32 and 33 to learn how to customize shapes and store them on custom stencils.

If the built-in shapes aren't what you want and you’re not ready to customize shapes and stencils, you can resort to building cubicles piece by piece with Panel shapes, Panel Post shapes, and shapes for work surfaces and storage units from the Cubicles stencil. Similarly, free-standing pieces such as Round Table and Stool shapes from the Office Furniture stencil can join a collection of shapes for a cubicle or workstation. When you have the cubicles configured the way you want, the best approach is to create a group of the shapes and copy the group to lay out the rest of the office.

To create a cubicle from components, follow these steps:

1. From the Cubicles stencil, drag Panel or Curved Panel shapes onto the drawing page. To resize panels or change their orientation, drag the ends of the shapes.
2. To connect panels, follow these steps:
   a. Drag a Panel Post shape onto the page and glue it to one end of a Panel shape. Visio highlights the connection point in red to indicate that the two shapes are glued.
   b. Drag the end of the adjacent Panel shape and glue it to a connection point (a blue asterisk) on the Panel Post shape. The Panel shape rotates into position based on the connection point you choose. For example, if you drag an end of a vertically oriented Panel shape over the connection point on the right side of a Panel Post shape, the Panel shape switches to horizontal.
3. To add furniture and equipment to a cubicle, drag one or more of the following shapes into the cubicle:
   ■ Modular work surfaces — From the Cubicles stencil, drag shapes such as Work Surface or Corner Surface and position them next to Panel shapes. To orient the shapes within the cubicle, use the shapes' rotation handles or the Rotate or Flip commands on the Shape menu.
Part V  Using Visio for Architecture and Engineering

- **Modular storage units** — From the Cubicles stencil, drag shapes such as Storage Unit and position them within the area defined by Panel shapes.

- **Suspended shelves and lateral files** — From the Cubicles stencil, drag shapes such as Susp Open Shelf or Suspended Lateral File on top of shapes for modular work surfaces. These shapes must align with the Panels in the cubicle because, in real life, they hang from the cubicle panels.

- **Chairs and other free-standing furniture** — From the Office Furniture and Office Accessories stencils, drag shapes into the cubicle area.

- **Computers and other equipment** — From the Office Equipment stencil, drag shapes into the cubicle area.

**NOTE**
You can also enhance cubicles by adding any shapes from the Cubicles stencil, Office Furniture stencil, Office Equipment stencil, or Office Accessories stencil to Visio built-in Workstation shapes or your customized workstations.

**Connecting Modular Furniture**
The shapes on the Office Furniture stencil are easy to connect because of the inward/outward connection points they contain (see Chapter 33 for an explanation of the different types of connection points). Modular furniture shapes glue and rotate to align with each other, similar to the Panel and Panel Post shapes for cubicles.

**Labeling and Numbering Plans**

Building plans are like other types of drawings when it comes to annotation. Text blocks, Callout shapes, and the text blocks within shapes themselves all have their place for showing information, notes, and comments. Because building plans are scaled drawings, you'll usually add Dimension shapes to show the distances represented on the plan.

In addition to these techniques, the Label Shapes add-on was developed specifically for building plans, although it's just as handy for labeling shapes on other types of drawings. With the Label Shapes add-on, you can display up to four shape data fields in labels on the shapes. For example, for a cubicle, you might display the person who sits there, the telephone number, the cubicle number, and department. You can also import data into the labels from other data sources.

The Number Shapes add-on is another tool you can't do without when working on plans, such as numbering the columns in a structural plan. This add-on numbers shapes in sequence or in the order you choose and uses the numbering scheme you specify, such as A-1 or Off-200.

To learn how to use the Number Shapes add-ons, see Chapter 6. The Label Shapes add-on is described in Chapter 28. And, of course, you can also label shapes with the new Data Graphics feature, described in Chapter 10.
Laying Out Architectural and Engineering Plans

To connect modular furniture, follow these steps:

1. From the Office Furniture stencil, drag a modular furniture shape, such as 45 Deg Table, onto the drawing page.

2. Drag a connection point on a second modular Office Furniture shape and position the pointer over a connection point on the first shape. When Visio highlights the connection points with a red square and rotates the second shape into the proper position, release the mouse button.

Modifying Cubicles

Predefined cubicles take care of adding cubicle walls, work surfaces, office equipment, and other furniture in one step. But, the built-in Visio Workstation shapes might not be set up the way you want. If a Workstation is close to what you need, you can modify one Workstation shape and duplicate it to populate your plan. For more significant changes or to create several versions of workstations, it’s more effective to create a custom stencil of Workstation shapes, as described in Chapters 32 and 33.

To modify a single cubicle or workstation, follow these steps:

1. From the Cubicles stencil, drag one of the Workstation shapes, such as an L workstation, onto the drawing page. The Workstation is a group of shapes with group selection handles.

2. To change the size of the cubicle, drag the Workstation shape’s selection handles. Shapes such as Panels and Work Surfaces resize automatically to match the new cubicle size. Shapes with fixed dimensions, such as chairs and suspended shelves do not change size, but might move within the boundary of the cubicle.

3. To move, delete, or format an individual component within the cubicle, select the Workstation shape and then subselect the individual shape inside it.
   - Drag the shape to reposition it.
   - Press Delete to delete it.
   - Choose standard formatting commands to reformat it.

4. To add furniture or equipment to the cubicle, drag a shape, such as Telephone, from the Office Equipment stencil, onto the Workstation shape. With the Workstation shape selected, Shift-click the new shape, and then choose Shape ➪ Grouping ➪ Add to Group.

5. To copy the Workstation shape, press Ctrl+D to create a duplicate and then drag it into position.

TIP: If the office layout is laid out on a grid, you can also use the Array Shapes command to create Workstation shapes at regular intervals both vertically and horizontally. For information on using Array shapes, see Chapter 4.
Creating Building Services Plans

The equipment and services required to keep a building running are a lot more than just building walls, openings, and furnishings. If you’ve ever been stuck at work when the power goes out, you already know how important electrical service is to getting any work done. Visio Professional includes templates for each building service, including electrical, plumbing, HVAC, and security systems. Most of the building services shapes include shortcut commands and shape data for selecting the type of component, specifying component dimensions, or configuring the shapes in numerous ways. In addition, these shapes come with layer assignments so it’s easy to manage building services plans with layers.

To learn more about using background pages, see Chapter 2. Chapter 26 describes how to use layers to control shapes. Chapter 29 discusses the use of CAD drawings within Visio drawings.
Adding HVAC Services

A few hours working in an office building when the air conditioning is turned off is all it takes to make HVAC an essential building service. Visio Professional offers two types of HVAC plans. An HVAC Plan shows the ductwork, registers, and diffusers that deliver and exhaust air. An HVAC Control Logic diagram represents the sensors and control equipment that determine the quantity and temperature of air that’s delivered.

Drawing HVAC Plans

The HVAC Plan template in Visio Professional automatically opens the stencils with HVAC equipment and ductwork. To add HVAC shapes to an existing drawing, open the same stencils by choosing File ➪ Shapes ➪ Maps and Floor Plans and then selecting the following stencils:

- **HVAC Equipment** — Includes pumps, condensers, fans, and other types of HVAC equipment
- **HVAC Ductwork** — Includes ducts, junctions, ductwork connections, and transitions
- **Registers, Grills and Diffusers** — Includes shapes for openings that deliver, remove, or diffuse air

The HVAC Plan also opens the Drawing Tool Shapes stencil, which is also available when you choose File ➪ Shapes ➪ Extras ➪ Drawing Tool Shapes. This stencil includes shapes that construct geometry useful in building ductwork.

Separating Building Services from the Basic Building

Building services plans use the exterior walls, structural elements, building core, interior walls, and, in some cases, cubicles to show where components such as sprinkler heads and electrical outlets go. In Visio, placing the basic building on a background page means that each building services plan can display the same basic plan for reference. If you build each building service plan on a different page in the same drawing file, you can associate the building plan background page with each building service plan foreground page. Using a background page also prevents you from inadvertently modifying the basic building plan as you work on building services.

Another approach is to add all the building service plan shapes to the same drawing page. In this case, layers on the drawing page act as separators, so you can turn off the layers you don’t want to see for a specific plan. For example, you could turn off the HVAC layer when you’re documenting the electrical service plan. With layers, you can protect the basic building components from editing by locking layers, such as Building Envelope, Wall, and Stair.

If you’ve imported a CAD drawing as a backdrop, you also lock that drawing against editing. To do so, right-click the drawing and then, from the shortcut menu, choose CAD Drawing Object ➪ Properties. In the CAD Drawing Properties dialog box, on the General tab, make sure both the Lock Size and Position check box and the Lock Against Deletion check box are checked.
To lay out HVAC ductwork and equipment, follow these steps:

1. Create a new drawing with the HVAC Plan template. You can also open an existing floor plan page, a page with an imported CAD drawing, or insert a new page in a floor plan drawing file.

2. To keep shape data easily accessible, open the Shape Data window by choosing View ➪ Shape Data Window.

3. Drag shapes that represent ductwork from the HVAC Ductwork stencil onto the drawing page.

4. To change the dimensions of a Ductwork shape, such as Straight Duct or Y Junction, use one of the following methods:
   - **Selection handles** — Drag selection handles to change the length or width of ducts.
   - **Control handles** — Drag control handles to change the angle of branches on ducts.
   - **Enter dimensions** — If the Shape Data window is open, select the Ductwork shape and then, in the Duct Length or Duct Width box, type the new length or width, respectively.

5. To connect Ductwork shapes on the drawing page, drag a connection point on one Ductwork shape to a connection point on the next Ductwork shape. For example, drag from a Branch Duct shape to the shape that represents the main duct. Visio highlights the connection points with a red square to indicate they’re glued and rotates the second Ductwork shape to match the orientation of the first.

   **NOTE**
   If you drag a Ductwork shape from a stencil, connect it to a Ductwork shape on the page by gluing one of its connection points to a connection point on the existing shape.

6. To change attributes for some ductwork shapes, right-click a shape and, from the shortcut menu, choose a command. For example, you can choose between Rectangular Duct and Circular Duct or specify whether the ends are open or closed.

7. To label ducts, use one of the following methods:
   - **Show duct size** — Right-click a Ductwork shape and, from the shortcut menu, choose Show Duct Size. Shapes that represent rectangular ducts show the duct width and depth. Shapes that represent circular ducts show the diameter followed by the diameter symbol.
   - **Add a text label** — As with other shapes, you can select a shape and type the label text you want. See Chapter 6 for instructions on working with shape text labels.

8. To add registers, grills, diffusers, and other types of HVAC equipment, drag shapes from either the Registers, Grills, and Diffusers stencil or the HVAC Equipment stencil and drop them on top of Ductwork shapes. These shapes don’t glue to Ductwork shapes or rotate to match the orientation of Ductwork shapes. However, dragging the rotation handles on these shapes change their orientation.
Documenting HVAC Control Logic

HVAC Control Logic diagrams show the sensors, equipment, and wiring that control the HVAC air flow system drawn on an HVAC plan. Unlike the HVAC Plan template, the HVAC Control Logic Diagram template creates unscaled schematic drawings by default. These schematics are single-line or double-line drawings that represent ducts, sensors, and mechanical equipment to control the HVAC system. The built-in shapes for sensors, equipment, and ductwork are all the same width, so the controls align nicely with ductwork as shown in Figure 27-4.

![Diagram of HVAC Control Logic](image)

Ducts and sensor shapes fit together so control diagrams are literally a snap to build.

Visio cleans up the intersections between ducts.

The alignment boxes for devices match duct width so they snap into place.

Many of the HVAC control shapes use shape data to configure controls more precisely. The values in drop-down lists vary from control shape to control shape, but the shape data fields are as follows:

- **Control** — Choose Control if the shape represents equipment that controls what the HVAC system does. Choose Sensor if the shape represents a sensor that measures some aspect of the HVAC system, such as temperature or humidity.
- **Type** — This field includes values for different variations of the device. For example, the Light shape includes Not Assigned, Solar Radiation, Ambient Space, Occupancy, and Other.
- **Limit Switch** — This field specifies whether the device has a shut-off switch that activates when the environment hits a high or low value. The choices include None, LowLimit, HighLimit, and Both.
**Part V**

**Using Visio for Architecture and Engineering**

- **Reset Switch** — Choose either None or Manual depending on whether the device includes a switch to reset it.
- **B-O-M Tag** — If you use the Visio diagram to build a bill of materials for the HVAC controls, in this field, type the ID for the device.
- **Part Number** — To track part numbers, for example, to find devices quickly in case of a recall, type the part number in this field.

Start a new HVAC Control Logic diagram by choosing File ➤ New ➤ Maps and Floor Plans ➤ HVAC Control Logic Diagram. If you want to include the control diagram in an existing drawing file, create a new drawing page and open the HVAC Control and HVAC Control Equipment stencils.

Use one or more of the following techniques to construct the diagram itself:

- **Add reference lines to the diagram** — If you’re building the diagram from scratch, drag guides from the horizontal and vertical rulers to provide reference points for adding ducts to the diagram.
- **Add ducts** — From the HVAC Controls Equipment stencil, drag Duct shapes, such as Duct, Return Duct, or Supply Duct, onto the drawing page and glue them to guides, the dynamic grid, or to other duct shapes. When ducts appear as double lines, add ducts to the diagram by positioning an end point of one Duct shape at the centerline of another Duct shape. If the ducts are perpendicular, the intersection between the ducts doesn’t show any overlapping lines. If the intersection between ducts doesn’t show an opening, as shown in Figure 27-4, right-click the Duct shape you are adding and choose Shape ➤ Bring to Front.

**TIP**

To show only the centerlines of ducts, right-click any Duct shape and, from the shortcut menu, choose Single Line Ducts.

- **Add equipment** — From the HVAC Controls Equipment stencil, drag Equipment shapes, such as Centrifugal Fan or Humidifier, onto the drawing page and place them on top of Duct shapes.
- **Add controls** — From the HVAC Controls stencil, drag Sensor shapes, such as Timer or Light, onto Duct shapes on the drawing page. The alignment boxes for these shapes match the width of Duct shapes so they snap into place, as illustrated in Figure 27-4.
- **Configure equipment and sensors** — In the Shape Data window, change the values for the shape data fields. If the Shape Data window isn’t open, you can also right-click a shape and choose Properties from the shortcut menu.
- **Resize ducts** — Drag duct end points. If you want to constrain the Duct shape to its current rotation, press Shift as you drag its end point.
- **Move ducts and controls** — If a Duct shape is glued to a guide, dragging Equipment and Sensor shapes onto the Duct shape also glues those shapes to the guide. To reposition the Duct shape and all of its associated Equipment and Sensor shapes, drag the guide to a new location. Glue horizontal Duct shapes to horizontal guides, and vertical Duct shapes to vertical guides.
Creating Reflected Ceiling Plans

The Reflected Ceiling Plan template doesn't include any tools specifically for creating reflected ceiling plans, so you can actually start with any plan template you want. For the ceiling grid itself, drawing tools, guides, and the Array Shapes command do the trick. After the ceiling grid is constructed, open the Electrical and Telecom stencil and the Registers, Grills, and Diffusers stencil (if they aren't open already) and drag shapes for light fixtures, air diffusers, and smoke detectors onto the plan.

Ceiling grids often repeat the same pattern of tiles and devices throughout most of a building. Because of this, a shortcut for producing an entire reflected ceiling plan is to draw a portion of the grid including ceiling tiles and ceiling-mounted equipment. Then, you can use the Array Shapes command to repeat that pattern of tiles and equipment throughout the rest of the building. Follow these steps to reproduce a ceiling grid pattern:

1. Drag guides onto the page to define reference points for one or more ceiling tiles. For example, position horizontal and vertical guides along the bottom and left edges of a corner ceiling tile.
2. Because Visio doesn't include a ceiling tile shape, use the Rectangle tool to create a ceiling tile.
3. Copy the ceiling tile to create all the tiles for the part of the ceiling grid that repeats. For example, if an array of four ceiling tiles represents the repeating pattern of tiles and ceiling-mounted equipment, use the Array Shapes command, Ctrl+D (Duplicate), or a combination of Ctrl+C and Ctrl+V (Copy and Paste) to create the additional ceiling tiles.
4. If the ceiling-mounted equipment is located at regular intervals in the grid, from the Electrical and Telecom stencil, drag lighting shapes onto the drawing. From the Registers, Grills, and Diffuser stencil, drag Diffuser shapes onto the drawing.

If the ceiling-mounted equipment is not located at regular intervals or some rooms have special equipment, drag that equipment onto the drawing after creating the array of repeating equipment.

5. Select the shapes for the ceiling tiles and ceiling-mounted equipment that you want to repeat.
6. Choose Tools &gt; Add-Ons &gt; Visio Extras &gt; Array Shapes.
7. In the Array Shapes dialog box, set the Spacing for Rows and Columns to zero, select the Between Shape Edges option, and then click OK. The Between Shape Edges option creates the next set of shapes in the array at the rightmost and topmost edge of the first set.

Adding Electrical and Telecom Services

The Electrical and Telecom stencil includes shapes for lighting fixtures, electrical switches, outlets, and other electrical devices for a home, building, or manufacturing plant. Start a diagram from scratch by choosing File &gt; New &gt; Maps and Floor Plans &gt; Electrical and Telecom. Because the Electrical and Telecom template doesn't include any specialized commands, it's often easier to
open the Electrical and Telecom stencil (File ➪ Shapes ➪ Maps and Floor Plans ➪ Building Plan ➪ Electrical and Telecom) while you work on an existing floor plan.

Most of the shapes on the Electrical and Telecom stencil include shape data for specifying different types of electrical devices. For example, the Switch Type property for the Switches shape can change the switch between Single Pole, 3 Way, 4 Way, Timer, and Weatherproof switches. Although the basic shape might stay the same, changing the type adds other graphics that indicate the specific type of component. A few shapes include shortcut menu commands for configuration, such as Flip Orientation, which flips the Switches shape about the horizontal or vertical access, depending on whether you want to attach the switch to a wall on the left or right side of a room.

Although switches and outlets are associated with walls in floor plans, Visio shapes for switches and outlets don’t rotate into position as Door and Window shapes do. To correct this omission, drag the rotation handle on the shape to rotate the shape into position. You can also rotate a shape to the left or right by 90 degrees by selecting the shape and then pressing Ctrl+L or Ctrl+R.

Visio also doesn’t offer a tool to draw wiring between electrical devices. You can use the Freeform tool or Pencil tool to draw connections between devices. To add wiring between two shapes, select the Freeform tool, drag from a connection point on the first shape, and drag slowly to the connection point where the wire ends.

To learn about the Freeform tool, see Chapter 4.

Adding Plumbing

The Plumbing and Piping Plan template creates a new scaled drawing and opens stencils with shapes you can use to show pipes, valves, and fixtures for water supply and wastewater disposal systems. You can start a diagram from scratch by choosing File ➪ New ➪ Maps and Floor Plans ➪ Plumbing and Piping Plan, but you can also open the following stencils by choosing File ➪ Shapes ➪ Maps and Floor Plans ➪ Building Plan while you work on an existing floor plan:

- **Pipes and Valves—Pipes 1 and 2** — These two stencils include dozens of linear shapes that represent pipelines and pipeline devices. Drag shapes for pipelines onto the page and glue each end to connection points on fixtures or plumbing equipment. You can resize pipeline shapes by dragging their end points.

- **Pipes and Valves—Valves 1 and 2** — These two stencils include all kinds of valves you can glue to the ends of pipeline shapes. For shapes that include shortcut commands or shape data, such as the In-line Valve shape, right-click the shape and choose a configuration command from its shortcut menu or select a value in a shape data field.

- **Plumbing** — This stencil offers standard plumbing shapes, including Boiler, Radiator, Toilet, and Bath. Bathroom shapes include both top view and side view shapes so you can show how fixtures are connected in a plan or cutaway view.
Adding Security and Access Systems

Unfortunately, good security becomes more important every day. Whether you’re designing a state-of-the-art security system for a top-secret development facility or setting up electronic access for a home or office building, the Security and Access Plan template helps prepare a diagram of security and building access features. You can start a diagram from scratch by choosing File ➤ New ➤ Maps and Floor Plans ➤ Security and Access Plan, but you can also open the following stencils (File ➤ Shapes ➤ Maps and Floor Plans ➤ Building Plan) while you work on an existing floor plan:

- **Alarm and Access Control** — Includes shapes for card readers, keypads, cameras, and other access devices
- **Initiation and Annunciation** — Includes shapes for paging and alarms
- **Video Surveillance** — Includes shapes for motion detectors, cameras, and other video equipment

Most of the shapes on the Security and Access stencils include shape data for specifying different device configurations. For example, the Mount Type property, which is associated with numerous shapes, specifies whether the device is mounted on the ceiling, on the wall, flush, hidden, or in other ways. On the drawing page, the shape label changes to reflect the type of mounting, the type of technology, and the function type.

Creating Site and Landscaping Plans

Site plans (available only in Visio Professional) come in two flavors, depending on the type of site information you want to show. Landscaping plans can be as intimate as a backyard garden for a town home — showing plants, fences, the sprinkler system, stepping stones, and recreational elements. Conversely, site plans often represent a much larger area and show landscaping, irrigation, parking, driveways, and traffic management features.

For smaller sites, an existing building plan is a perfect place to start. You can use the building plan as a background and add site details on a foreground drawing in relation to the building. For larger sites, a separate site plan is usually required simply because the larger area needs a smaller scale to fit onto the drawing page.

To create a site plan from scratch, choose File ➤ New ➤ Maps and Floor Plans ➤ Site Plan. Visio creates a new drawing using a civil engineering scale of 1" = 10'0". This scale fits a site 360 feet by 240 feet on the architectural drawing page. If your site is larger than that, you can choose predefined civil engineering scales up to 1" = 100'0" or you can set a custom scale.

If you use an existing building plan, your buildings are already on the drawing page. However, when you start a new site plan with the Site Plan template, you must draw building outlines using drawing tools such as Line, Rectangle, or Pencil.
Adding Landscaping Elements

Several stencils provide shapes for the plantings and constructed landscaping features. These shapes work equally well for commercial landscaping and home garden layouts. Drag shapes from the following stencils to add landscaping elements to the site plan:

- **Garden Accessories** — Includes shapes for fences, posts, and gates; and shapes for surfaces, such as flagstone, brick pathways, concrete, driveways, and patios.
- **Irrigation** — Includes shapes for irrigation lines, spray heads, valves, and other devices. These shapes include shape data for specifying different types of irrigation devices.
- **Planting** — Includes shapes for different types of trees, shrubs, hedges, and potted plants. Label plants with both common names and plant descriptions with the Plant Callout shape.
- **Sport Fields and Recreation** — Includes shapes for recreational equipment, such as pools, swing sets, and different types of sports fields.

Landscaping elements often end up positioned at regular intervals, whether you are planting a grid of palm trees or constructing a brick sidewalk. To create and arrange shapes at regular intervals vertically and horizontally, use the Array Shapes command.

To learn how to apply the Array Shapes command, see Chapter 4.

Working with Roads and Parking Lots

The Site Plan template opens both the Parking and Road stencil and the Vehicles stencil. The Parking and Road stencil include shapes for roads, driveways, parking stalls and lots, sidewalk ramps, and traffic islands. By adding shapes from the Vehicles stencil to the plan, you can make sure that vehicles of different sizes can navigate the site.

Creating Roads and Parking Lots

To create roads and parking lots, follow these steps:

1. Drag guides onto the drawing page to mark reference points for the perimeter of the site, roads, and parking stalls.
2. Drag Curb and Driveway shapes onto the drawing page. To connect Curb and Driveway shapes, use the Line tool to draw lines between the shapes.
3. To add parking strips, stalls, and islands, drag shapes from the Parking and Roads stencil onto the drawing page. Glue their end points to guides on the page to simplify repositioning them.
4. Parking stall shapes and parking strip shapes glue to the end points or control points of Island shapes. Simply drag parking stall or parking strip shapes to Island shapes and drop them into place when Visio highlights their connection points with red boxes.
5. If you drag individual Parking Stall shapes onto the page and glue them to a guide, you can reposition all the Parking Stall shapes at once by dragging the guide to which they are glued.

6. Drag shapes from the Vehicles, Site Accessories, and Planting stencils, to show vehicles, parking lot components, drains, outdoor furniture, and plants. Glue shape end points to guides.

Modifying Parking and Road Shapes

Parking and Road shapes include selection and control handles for reconfiguring the shapes. Unlike mall parking at holiday time, some shapes, such as the Parking Strip shape, are extendable, and add additional parking stalls as you drag the selection handle at either end of the shape. Other shapes include control handles, such as the control handle on the Radial Strip shape, which changes the number of stalls as you drag it, as shown in Figure 27-5.

**FIGURE 27-5**

Use glue and control handles to position and configure parking stalls.
To find out what a control handle does, position the pointer over the control handle until the screen tip appears.

Some shapes include shape data for further configuration. For example, the Parking Strip and Parking Stall shapes include a Stall Angle shape data field. By default, Visio parking stalls are oriented at seventy degrees. To create straight parking stalls, on the drawing page, right-click a Parking Strip or Parking Stall shape and, from the shortcut menu, choose Properties. In the Stall Angle box, type 90deg, and click OK. The values in the Stall Width and Stall Length fields determine the size of the parking stall, which is ideal for creating parking stalls for compact cars and monster trucks alike. Shapes with curves, such as Curbs, include a Radius property that controls the radius of the curve on the shape.

Some Parking shapes include shortcut commands to reconfigure the shape. For example, with the Radial Strip shape, you can choose Stalls Inside or Stalls Outside from the shortcut menu to change whether the stalls face the inside radius or outside radius for the shape.

### Drawing Directional Maps

Another type of Visio drawing that covers an even larger area than that of site plans is the directional map. With the Directional Map template, you can create road maps that show how to drive to your destination, or metro maps that help users navigate the transportation system in a city. These maps can include roads, transportation lines, as well as landmarks. In Visio, three-dimensional Directional Map shapes make it easy to render small geographic areas, such as villages or towns, with appealing and colorful three-dimensional shapes. By default, Visio creates maps without scale, but you can indicate an approximate scale by adding text to a Scale shape.

The Directional Map templates are available in both Visio Standard and Visio Professional.

### Creating Road and Metro Maps

To create a directional map, follow these steps:

1. Choose File ➤ New ➤ Maps and Floor Plans ➤ Directional Map.
2. To add roads to the map, drag a shape, such as Road Square, Curve 2, or Railroad from the Road Shapes stencil onto the drawing page. You can resize Road shapes by dragging their end points.
3. To specify the thickness of a Road shape, right-click the shape and, from the shortcut menu, choose Thin, Standard, Thick, or Custom. If you choose Custom, drag the control handle to specify the thickness you want.

To change the direction of a Road shape, right-click the shape and choose one of the Rotate or Flip commands. You can also click Rotate or Flip buttons on the Action tool-bar or use keyboard shortcuts such as Ctrl+L and Ctrl+R to rotate a shape ninety degrees to the left or right.
4. To simplify moving multiple road segments at once, glue Road shapes to guides and then drag the guides to reposition the shapes.

5. Drag 3-Way, 4-Way, Roundabout, and Interchange shapes onto the drawing page to represent intersections. Glue end points for Road shapes to connection points on the intersection shapes.

6. Identify numbered roadways by dragging shapes, such as Interstate and State Route, onto the page near the Roadshape you want to identify. Double-click the identifier shape and type the interstate highway number, route number, or road number.

7. To draw metro or subway systems, use shapes on the Metro Shapes stencil. These shapes work similarly to Road shapes, but also include shapes to show stations and stops.

8. To indicate landmarks such as lakes, rivers, airports, malls, schools, and hospitals, drag the appropriate shapes onto the map. You can drag selection handles to resize Landmark shapes in one direction or proportionally.

9. To add transportation signs, such as one-way street signs or freeway exits, drag shapes from the Transportation Shapes stencil.

10. To indicate the location of recreational areas, drag shapes from the Recreation Shapes stencil.

**Modifying Roads and Intersections**

Visio Road shapes are quite simple, but the combination of straight, curved, and flexible Road shapes do a good job of representing roads for a directional map. The following are some methods for modifying roads and intersections on a map:

- **Set Default Road Thickness** — To specify the thickness for different types of roads, make sure no shapes are selected and then right-click the drawing page and choose Data Shape Data. In the Shape Data dialog box, type values for Road Width, Primary Route Width, Narrow Road/Street Width, and Metro Width.

- **3-way and 4-way intersections and interchanges** — To change the thickness of intersection roadways, right-click the shape and, from the shortcut menu, choose the thickness you want (Thin Road, Standard Road, Thick Road, or Custom). All arms of the shape change to the same thickness. To change the length of vertical or horizontal intersection arms, drag the selection handles on the sides or the top and bottom of the shape. To lengthen all the arms, drag one of the corner selection handles.

- **Flexible roads or flexible metros** — To change the thickness of intersection roadways, right-click the shape and, from the shortcut menu, choose the thickness you want. Use one or more of the following methods to modify a flexible shape:
  - **Change a curve** — To reposition points or redefine a curve, on the Drawing toolbar, click the Pencil tool. Drag a vertex or selection handle.
  - **Add a vertex** — Click the Pencil tool on the Drawing toolbar. Then Ctrl-click the shape where you want to add the vertex.
Annotating Maps

Basic Visio annotation techniques are all you need to add notes to your directional maps. The Landmark Shapes stencil includes several Text Block shapes for adding text at different font sizes. You can use the Callout shape to add text and point it to an element on the map.

Shapes on the Landmark Shapes stencil indicate scale and direction for maps. Although maps are unscaled by default, a Scale shape on the drawing page can indicate an approximate scale of the map. Select the Scale shape and type the total distance that the shape represents. To indicate direction, drag either the Direction or North shape onto the drawing page. Drag the rotation handles on either of these shapes so that north is pointing in the right direction.

Using 3-D Map Shapes

Three-dimensional directional maps are perfect for producing illustrated maps or tourist guides. These maps aren’t to scale, but show buildings, roads, and landmarks in an isometric three-dimensional view. To create a three-dimensional map, you choose File ➪ New ➪ Maps and Floor Plans ➪ Directional Map 3-D and then drag and drop shapes from the Directional Map Shapes 3-D stencil onto the drawing page. You use standard Visio techniques to work with these shapes, including the following:

- Dragging selection handles to resize the shapes
- Using Ctrl+D to quickly duplicate shapes, such as road segments
- Using rotation handles to rotate shapes
- Grouping shapes so you can move them as one
- Adding text to shapes by selecting the shape and typing

Summary

Visio Professional includes templates for numerous types of architectural and engineering plans, as well as directional maps. By placing the shapes for the building shell and core on a background page, they are readily available as reference for the components for other types of plans, such as building services. Most of the shapes for architectural and engineering plans include shortcut menu commands, control handles, and shape data for modifying shape configuration. In addition, shape data is equally effective for creating component schedules and other types of reports.

Directional maps show larger areas than building or site plans. Although they are unscaled in Visio by default, they still represent real-world distances. You can drag and glue shapes together to depict roads, metros, and landmarks for road and city maps.
Space plans are valuable tools from the very first thoughts about building design to the ongoing management of facilities after they’re built and occupied. Early on, space plans help determine the optimal arrangement of building space to meet organizational needs. It’s much easier to move simple outlines around to figure out adjacencies like whether the conference room should be closer to the reception area or the executive offices. Then, when buildings are occupied, space plans help track the use of space by different departments, identify the location of resources, and put those spaces to best use and the resources in the most appropriate locations.

For basic space planning, such as arranging the rooms for your new home or office, the Office Layout template available in both Visio Standard and Visio Professional is all you need. By dragging and dropping Space and Room shapes from the Walls, Doors, and Windows stencil, you can shuffle the shapes around and resize them until you’re satisfied with the layout.

However, for larger-scale space planning or facilities management (tracking and managing who and what goes where in facilities), only the Space Plan template in Visio Professional can help. This template enables you to build a model of spaces, assets, and resources, which you can use to plan the best use of space, track usage, and analyze changes and upcoming moves.

Space and facilities management plans process significant amounts of data — space assignments, asset tags, resource locations, and more. Building these plans with Space Plan template tools and incorporating Visio data features can turn your existing facilities data into a visual model of your facilities.

This chapter begins by showing you how to create space plans using the Space Plan Startup Wizard, either by importing spaces using the Import Data
Understanding Space Planning and Facilities Management Using Visio

Space planning typically means arranging space within a building so that groups obtain the space they need and business processes operate efficiently. High-level space planning can begin with a few hand-drawn ovals on a napkin, but eventually planning the detailed layout of spaces within a building shell involves studying organizational processes and needs, work flows, architectural requirements, and more. A more fastidious cousin to space planning, facilities management usually translates to tracking and relocating people, computers, equipment, and furniture to respond to reorganizations and office moves. Some organizations take facilities management further to include facilities maintenance. For example, by tracking when lightbulbs are changed, the maintenance department can develop plans to keep areas lit.

Visio Space Planning Tools

The tools to produce high-level space plans are available in both Visio Standard and Visio Professional. For more detailed space planning and facilities management, Visio Professional and the Space Plan template are a must. Depending on the type of planning you want to do, choose from the following Visio features:

- **Conceptual Planning** — For sketching general ideas of space arrangements, the Ink tool or the Ellipse tool can produce rough outlines of space on a drawing page. Select the Ink or Ellipse shape you've added and type the name of the area. To show spaces that should be located near each other, draw arrows between shapes.

- **Detailed conceptual planning** — When you have an existing building shell to divvy up into spaces or you know the amount of space each department needs, Visio Space shapes are convenient planning tools. Space shapes appear on the Walls, Doors, and Windows stencil and the Walls, Shell, and Structure stencil. Drag Space shapes onto the page and resize them until the value for the area displayed within the shape matches a department's allocation. Space shapes work equally well on blank drawings, existing Visio plans, or on top of imported CAD drawings.

- **Detailed space planning** — When you're planning space within a fully constructed building, you can drag Space shapes onto the page and resize them not only to meet a department allocation, but also to fit within the Wall shapes that represent constructed walls. The Auto-Fit command on a Space shape's shortcut menu fits the space to existing shapes on the floor plan.

No matter which type of space planning you want to do, Space shapes help you focus on the abstract spaces. The shape data associated with Space shapes helps track information, such as the
intended use for a space (such as office or conference room), the name of the space, the department using it, its occupancy, and more. During initial space planning, the name of the space or the department might be sufficient and adding those values manually might be acceptable. As you develop more detailed plans, especially for large facilities, filling in all the shape data fields by importing facilities data is faster and less error-prone.

To help you size and lay out spaces properly, Space shapes automatically calculate and display the area they enclose. Feel free to change the color and fill pattern of Space shapes to differentiate spaces during the planning process. Later, you can convert Space shapes to Wall shapes and begin a detailed building plan, as described in Chapter 27.

Managing Facilities with Visio Features

For small facilities, management can be as simple as relocating Visio shapes on a drawing page. However, for larger facilities or more systematic tracking and management, Visio Professional offers specialized tools to track space and assets accurately, and can use external data to automatically refresh plans with data changes. Visio Professional space planning tools aid in performing the following facilities management tasks:

- Develop space plans that reflect the physical spaces you manage.
- Associate people and assets, such as equipment and furniture, with areas and space by importing data from a spreadsheet or database.
- Allocate unassigned people and assets to spaces in the plan.
- Reassign people and assets by dragging shapes from one space to another in the Space Plan model or on drawing pages.
- Automatically update the space plan when data in the spreadsheet or database changes.

Because facilities management relies so heavily on data, setting up full-blown space planning and facilities management plans requires more work than many other types of drawings. It helps to have a database administrator working with you to make sure Visio and your organization’s facilities database play well together. Fortunately, the Visio Space Plan Startup Wizard simplifies these setup steps considerably. Before you can track and manage resources in a Visio plan, you must complete the following tasks, which are described later in this chapter:

- Prepare your facilities data in your external data source.
- Import your facilities data into a space plan using the Space Plan Startup Wizard or the Import Data Wizard.
- Set up your space plan to refresh when the data in your external data source changes.
- Make sure that all spaces are placed in your space plan using the Space Explorer window.
- Assign people and resources to the correct categories and spaces using the Space or Category Explorer window.
- Make sure that unassigned people and resources are assigned to spaces using the Space or Category Explorer window.
Exploring the Space Plan Template

The Space Plan template (remember, available only in Visio Professional) is one of the more powerful Visio templates with features for laying out spaces, importing data, and tracking facilities. When you create a new drawing using the Space Plan template, the template adds the Plan menu to the Visio menu bar and opens stencils associated with space planning and facilities management. The Space Plan template also launches the Space Plan Startup Wizard to help you configure the data that represents your spaces, assets, and resources. The Import Data Wizard is an additional tool for setting up data on an existing plan. For space plans, Visio opens a letter-size drawing using landscape orientation and a scale of $\frac{1}{8}" = 1' 0"$.

Menus and Stencils

Don’t be disappointed when the Space Plan template adds a Plan menu to the Visio menu bar. Unlike its architectural and engineering plan counterparts, the Plan menu for the Space Plan template contains more than the Convert to Walls and Set Display Options commands. This Plan menu includes the following additional entries:

- **Explorer** — This menu entry toggles the display of the Explorer window, which displays the space plan model, described in the next section.
- **Color By Values** — Choose this entry to launch the Color By Values add-on, which associates colors with space shape data values, as described in Color-Coding Space Plans.
- **Label Shapes** — This menu entry launches the Label Shapes add-on, which displays shape data values within the shapes on the drawing page.
- **Assign Category** — The shapes on a space plan fall into one of several categories: Asset, Boundary, Computer, Person, Printer, and Space. Each category comes with a set of shape data fields specifically for tracking that type of resource. The section “Assigning Categories to Resources” later in this chapter explains how to assign categories and put them to use.
- **Import Data** — This menu entry launches the Import Data Wizard for importing facilities data into shapes on a drawing page, as described in the section “Adding Spaces Using the Import Data Wizard.”
- **Refresh Data** — Choose this entry to refresh the facilities data that appears on a space plan from your external data source.

The Space Plan template also opens the Resources stencil, which includes Space and Boundary shapes for delineating departments, offices, and other areas in a building. The Resources stencil also includes shapes that represent resources, such as Person, Computer, and Asset for identifying the people, computers, and other assets (such as furniture) that inhabit the spaces. The Report shapes on the Resources stencil are an easy way to create predefined facilities management reports quickly and easily.
Using the Space and Category Explorers

Because a Visio space plan is also a model of your facilities, the Space and Category Explorers provide an alternate, and sometimes preferable, way to view and modify spaces and resources. First, the Space and Category Explorers show the relationships between model components in an outline view, so you can immediately identify which resources belong to which spaces, and which spaces are contained within larger areas. In addition, the model shows all the spaces and resources for your space plan, not just the ones that appear on drawing pages.

The Space Explorer displays a hierarchy of boundaries, shapes, and resources, where boundaries represent larger areas such as departments, shapes represent offices or rooms, and resources represent people, computers, or other assets associated with spaces. For example, you can associate people and equipment to offices, and offices to departments. In the Space Explorer, you can see which resources are located in which spaces, as shown in Figure 28-1, regardless of which drawing page shows them. The Category Explorer groups elements in the space plan by category, such as Person, Computer, or Space.

When you open a new space plan, the Space and Category Explorer windows appear in one docked window, with tabs for each Explorer window. You can hide or show both of the Explorer windows by choosing Plan ➪ Explorer. To float each window individually, right-click its tab and, from the shortcut menu, choose Float Window. To float the entire window with both Explorer windows in it, drag the window title bar to a new location.

In Figure 28-1, the Explorer windows are docked within the Shapes window to display as much of the drawing window as possible. To dock the Explorer windows there, drag the Explorer title bar into the Shapes window and release the mouse button.

Here are methods for managing spaces and resources with the Space Explorer and the Category Explorer:

- **Locate and select spaces and resources on a drawing page** — In either Explorer window, right-click a space or resource and, from the shortcut menu, choose Show. Visio displays the drawing page on which the corresponding Space or Resource shape is located, centers the shape in the drawing window, and selects the shape on the page.

- **Move resources between drawing pages** — Instead of cutting a shape from one page and pasting it onto another, in the Space Explorer, drag a person or asset from one space to another. The corresponding shape moves on the drawing as well.

- **Enter resource information** — In either Explorer window, right-click a resource and, from the shortcut menu, choose Properties. In the Shape Data dialog box, click a shape data field and type or select a value. The value you type in the Name field appears by default in the Explorer windows and on the shape on the drawing page.
FIGURE 28-1

The Space and Category Explorers dock in the same window, showing spaces and the people and assets assigned to them.

- **Rename resources and assets** — In either Explorer window, right-click a resource or asset and, from the shortcut menu, choose Rename. Visio selects the name in the Explorer window, so you simply type the new name to replace the existing one.

- **Assign resources to spaces** — If people or assets have not yet found a home in a space in the plan, in either Explorer window, expand Unplaced Data. Drag a resource or asset from the Unplaced Data area to a Space shape on a drawing page.

**NOTE**

The drawing pages might not include all spaces, people, or assets for your space plan. The Unplaced Data folder in either Explorer window shows the spaces and resources that don’t exist on drawing pages.

- **Delete resources** — To delete a person or asset both in the model and on the drawing page, in either Explorer window, select a resource and press Delete.
Creating Space Plans

The amount of detail in space plans depends on their purpose. Space plans for prototyping the arrangement of departments and offices can be quite sparse—a name and department might be all you need to identify the spaces. Space plans used to manage the assets, personnel, and space in a facility are often loaded with detailed data and kept up to date with real-world facility changes. Because of the tools that the Space Plan template provides, you’ll want to start a space plan by choosing File ➪ New ➪ Maps and Floor Plans ➪ Space Plan to create your Visio drawing. After the file is open, the method you use to create your space plan depends on what you intend to do with the plan:

- **Preliminary layouts** — For prototyping, you don’t need detailed building outlines or floor plans. When the Space Plan Startup Wizard opens, cancel it and start by using drawing tools on the Drawing toolbar to sketch the outline of floors. Then, drag Space shapes onto the drawing and move them around with standard Visio techniques to layout the spaces. Alternatively, you can jump right in and start dragging Space shapes onto the page without any building outline.

- **Detailed layouts** — To begin arranging spaces within the confines of a building shell, take advantage of the Space Plan Startup Wizard to display a floor plan as a backdrop. If you have a list of spaces in an Excel workbook, the wizard can creates shapes for those spaces. You can still drag Space shapes onto the drawing and move them around. The Auto Size command on Space shape shortcut menus modifies Space shape borders to fit the walls on the drawing.

- **Tracking plans** — When you want to track resources on a Visio space plan, you need accurate and detailed information. When you create a space plan with the Space Plan template, the Space Plan Startup Wizard opens, in which you can add a background floor plan and add Space shapes based on a list of room numbers and names. The shapes added by the wizard appear on the drawing page and in the Explorer windows. You still must add other spaces not in the original list, add resources, and associate them with spaces.

Suppose you have a floor plan drawing file that you want to use as the basis for a space plan. The building shell and walls are there, but the Plan menu lacks the specialized space plan commands in Visio. To make all the space planning tools available on the Plan menu, choose Tools ➪ Add-Ons ➪ Maps and Floor Plans ➪ Enable Space Plan.

Using the Space Plan Startup Wizard

By no means does the Space Plan Startup Wizard do everything for you. Nor is it a totally flexible and all-powerful data import tool. What it does is simplify a few of the steps in setting up a new space plan. With this wizard, you can specify a floor plan to use as a background for your space plan and create spaces based on the room numbers in an Excel workbook.
Creating Space Plans Using the Wizard

To use the Space Plan Startup Wizard to create a space plan, follow these steps:

1. Choose File ➤ New ➤ Maps and Floor Plans ➤ Space Plan. The Space Plan Startup Wizard launches automatically after Visio creates a new space plan drawing.

2. On the first screen of the Space Plan Startup Wizard, select the type of image or drawing you want to use as a background for your space plan:
   - **Image** — Select this option to display a graphics file of the building, such as a JPG or GIF file.
   - **Visio Drawing** — This option enables you to select an existing Visio drawing to use as an underlying plan for your space plan.
   - **CAD Drawing** — If your building shell or floor plan resides in a CAD drawing file, select this option.
   - **None** — Select this option if you plan to draw the outline of the building with Visio tools.

3. Click Next. If you chose to use a graphics file or a drawing, a dialog box opens in which you select the graphics file or drawing file you want to use. Click Open to use that file and proceed to the next part of the wizard.

4. On the next wizard screen (the Get Room List screen), select the option for the source of spaces you want to add to your space plan. You can use an existing Excel spreadsheet, create a new spreadsheet in the wizard, or type the room numbers manually.

5. Click Next. If you use an existing spreadsheet, which is the most dependable approach, on the next wizard screen, shown in Figure 28-2, do the following:
   a. Next to the Choose The Excel Spreadsheet File That Contains Room Information box, click Browse and open the Excel workbook that contains your room data.
   b. If the workbook includes more than one worksheet or named ranges, in the Choose The Worksheet Or Range drop-down list, choose the worksheet or range. (Visio populates the drop-down list with the worksheets and named ranges in the selected Excel workbook.)
   c. In the Select The Column That Contains Room Numbers drop-down list, choose the column that contains the room numbers.
You can choose an Excel spreadsheet, including the specific worksheet and column, to feed room numbers to the Space Plan Startup Wizard.

**FIGURE 28-2**

![Space Plan Startup Wizard](image)

6. Click Next. On the final wizard screen, click Finish. Visio adds the spaces to the Category and Space Explorers. If Visio finds a shape on a drawing page with a matching room number, it lists the space under that drawing page in the Space Explorer hierarchy. Otherwise, it shows the spaces under the Unplaced heading.

7. For spaces that the wizard doesn’t place on the drawing page, from the Space or Category Explorer window Unplaced Data folder, drag unplaced spaces onto the drawing page, making sure not to overlap Space shapes. Visio creates Space shapes for each unplaced space you drop onto the drawing. To resize a Space shape, drag any of its selection handles.

**Using Shapes to Create Space Plans**

If you build space plans from your facilities data, the Import Data Wizard is the easiest way to add new spaces. However, you can also add these elements by dragging shapes onto drawing pages. In the Resources stencil, the Boundary shape is intended to depict larger areas such as departments or divisions. The Space shape acts as a container for the resources assigned to a specific space or office.

**CAUTION**

To ensure that spaces are assigned to boundaries, and resources are assigned to spaces, add Boundary shapes to your drawing page first, followed by Space shapes, and finally Person, Asset, Computer, and Printer shapes. If you’ve already added these elements in a different order, correct the assignments in an Explorer window by dragging spaces to the proper boundary or resources to the proper spaces.
Manually Creating Spaces

Define spaces on a Visio space plan using any of the following methods:

- Designate larger areas, such as departments, by dragging Boundary shapes onto the drawing page. You can drop Space shapes inside a Boundary shape to assign specific offices to a department. However, you can’t assign people or assets to boundaries. The Boundary shape displays the square footage it encloses, so you can use it to show the area of multiple Space shapes.

- From the Resources stencil, drag a Space shape onto the drawing page. Visio adds a 100-square-foot square space by default. If you drag the shape’s selection handles to resize it, Visio updates the square footage that appears within the shape when you select it, as shown in Figure 28-3.

**FIGURE 28-3**

Space shapes automatically display the area that they enclose.

TIP

If the floor plan contains Wall or Room shapes, you can automatically adjust a Space shape to fit an area in the floor plan. After dropping the Space shape into the area, right-click it and, from the shortcut menu, choose Auto-Fit. Visio changes the outline of the Space shape to match the perimeter defined by the Wall shapes on the floor plan and displays the new enclosed area in the Space shape text block.
Use drawing tools to outline spaces and then convert the drawing shapes to Space shapes. To do this, choose Plan ➪ Assign Category. In the Assign Category dialog box, select Space in the Category drop-down list and click OK. Visio converts the outlined shape into a Space shape and displays the calculated area in a text block within the shape.

To ensure that the area on your space plan is calculated correctly, do not overlap Space shapes. When Space shapes overlap, the overall calculated space area will be greater than the area within your building.

When you intend to import facilities data from a spreadsheet or database, spaces must include a value in their Name field, so there’s a way to match the space with a record in your data source. The value you specify must match a unique identifier in the spreadsheet or database. For example, if the office room number in the spreadsheet is 301, type 301 in the Space shape’s Name field. To do this, follow these steps:

1. If the Shape Data window is not open, choose View ➪ Shape Data Window.
2. Select the Space shape on the drawing page.
3. In the Shape Data window, click the Name field and type the value that matches the identifier in the data source.

You can also specify the intended purpose of a Boundary or Space shape in the Shape Data window by clicking the Space Use field and typing the purpose or selecting one of the predefined purposes (Office, Conference, Storage, Other) in the drop-down list.

Modifying Boundary and Space Outlines
Although the Space and Boundary shapes on the Resources stencil are 100-square-foot squares by default, you aren’t stuck with rectangular areas. Boundary and Space shapes respond to basic Visio tools just like any other shapes. No matter how you indent and contort the outline or size of these shapes, Visio calculates the new total for the enclosed area and displays it within the shape. Here are methods for modifying the perimeters of Boundary and Space shapes:

- **Resize a Space or Boundary shape** — Drag any selection handle on one of these shapes to resize it as you would any other type of shape.

- **Reshape a Space or Boundary shape** — To change the angles of the sides or to add indents and notches to a space or boundary, right-click the shape and then, from the shortcut menu, choose Edit (or, on the Drawing toolbar, click the Pencil tool). Then choose from the following methods:
  - Add a new vertex by Ctrl-clicking the outline of the shape.
  - Move a vertex by positioning the pointer directly over it. When the pointer changes to a four-headed arrow and the vertex turns magenta, drag the vertex to a new location.
To select more than one vertex to move, Shift-click each vertex and then drag to a new location.

- **Auto-size a shape** — If the Wall shapes that surround a Space shape change, you can refit the shape to the new wall configuration by right-clicking the Space shape and, from the shortcut menu, choosing Auto-Size.

## Assigning Resources to Space Plans

To use Visio drawings to track and manage the people, equipment, furniture, and other assets that occupy your facilities, you must first assign those items to categories and then assign them to spaces in a space plan. The Visio Space Plan template pigeonholes spaces and resources in six categories, each with its own set of predefined shape data fields:

- **Boundary** — A location category that represents larger areas within a building, such as departments or functional uses
- **Space** — A location category that represents specific spaces such as offices or rooms and can contain other resources, such as people or assets
- **Person** — Represents the human resources assigned to work in spaces
- **Computer** — An asset category specifically for computer equipment
- **Printer** — An asset category specifically for printers
- **Asset** — A generic asset category for tracking any other kind of asset

You can’t rename the built-in categories or define your own.

Each category carries a different set of shape data fields, appropriate for the type of resource. For example, the shape data fields for the People category include Name, Title, Phone Number, E-mail Alias, Manager, and Department. The Printer category focuses on tracking information, such as Asset Number, Serial Number, Manufacturer, Product Number, and so on. By assigning spaces and resources to categories, you can view the items on a plan and produce facilities reports by category. The hierarchy in the Space Explorer starts with boundaries and then shows the spaces within boundaries, and then the people and assets within each space.

## Adding Resources to Space Plans

To track resources, they must be part of your space plan model. As with spaces, you can add resources to your model manually or by importing resource data:

- **Add resources manually** — It’s easy to add resources to space plans, because the Resources stencil includes a shape for each type of resource. Dragging these shapes onto a drawing page automatically assigns the shape to the correct category. Shapes on the Resources stencil also include layer assignments to a layer of the same name as the resource category, such as Space, Person, and Computer. In the Shape Data window, in the Name field, type the name or an identifier for person or asset.
Shapes other than those on the Resources stencil are fair game for a space plan—as long as you assign them to a category, as described in the section “Assigning Categories to Resources” later in this chapter. For example, you might want to use custom shapes to represent different types of computers, or assign furniture shapes to the Asset category.

- **Import resources**—Choose Plan ➤ Import Data to use the Import Data Wizard to create shapes for people and assets, and link external data to the shape data. The Import Data Wizard uses the masters on the Resources stencil to create shapes on the drawing page. For instructions on how to use the Import Data Wizard, see the section “Using Visio Space Plans to Manage Facilities” later in this chapter.

### Placing Unassigned Resources

The Import Data Wizard automatically assigns resources to spaces—if it can match a space identifier in a resource record in the external data source with a space identifier in the Visio space plan model. If a person or asset doesn’t have a space assignment or the wizard can’t make a match, it places the people or assets in the Unplaced Data folder, which you see in the Space and Category Explorer windows.

To assign an unplaced resource in the Space Explorer window, do the following:

1. Next to the Unplaced Data folder, click the plus sign to expand the folder.
2. From the Unplaced Data folder, drag an unassigned person or asset onto the icon in the Space Explorer that represents the space to which you want to assign the unplaced item. Visio adds a shape for the person or asset to the Space shape on the drawing page as well.

You can also assign a person or asset by dragging the resource from the Unplaced Data folder onto a Space shape on the drawing page. Visio adds a shape to the drawing and, in the Explorer window, moves the resource from the Unplaced Data folder to the icon that represents the space containing the resource.

### Assigning Categories to Resources

The shapes on the Resources stencil all look about the same—they’re small rectangles with an even smaller graphic to differentiate people, computers, printers, and other assets. If you would rather use more recognizable shapes on a space plan, you can assign categories to any Visio shape. For example, you could assign categories to the shapes from the Office Equipment or Office Furniture stencils. When these shapes are assigned to categories, you get the best of both worlds—not only do the shapes on the drawing page depict the resources they represent, but they also take on the shape data fields for the category and appear in the appropriate category in the Category Explorer window.

Assigning a shape to a category applies the category shape data fields to that shape. What if the shape already has shape data fields with values that you don’t want to give up? The Assign Category command includes a feature for mapping existing shape data fields to the ones for the category.
To assign a category to a shape, follow these steps:

1. Select all the shapes on the drawing page that you want to assign to the same category.
2. Choose Plan ▶ Assign Category.
3. In the Assign Category dialog box, in the Category drop-down list, select the category to which you want to assign the shapes.
4. If the shapes you selected have shape data associated with them, map these fields to the predefined space plan field by doing the following:
   a. Click Properties. The Properties dialog box opens.
   b. Under Properties, select an existing shape data field.
   c. Under Category Properties, select the predefined category property to which you want to map the original shape data field.
   d. Click Add to map the fields, as shown in Figure 28-4.

   ![Figure 28-4](image)
   You can transfer data from shape data fields to category fields by mapping the two while assigning a category to a shape.

   Shape data fields  
   Category fields  
   Mapping between the two fields

e. Repeat steps b, c, and d for each field you want to map.

f. Click OK when you're done.

**NOTE** Shape data fields that you don't map remain associated with shapes so you won't lose any existing data.

5. In the Assign Category dialog box, click OK.
Using Visio Space Plans to Manage Facilities

People, computers, equipment, and furniture seem to relocate continuously in response to reorganizations and office moves, so any way to simplify tracking these resources is welcome. By displaying spaces and resources on a Visio space plan, you have a graphic map to where things are within the facilities you manage. Visio can also produce facilities reports to show departments the space and resources they have or to charge groups for the space and assets they use. All this convenience requires some work up front—a Visio space plan has to have space plan or facilities data associated with the shapes. That’s where the Import Data Wizard comes into play.

The Import Data Wizard can grab data from external data sources and use them to create spaces and resources on a Visio space plan. Regardless whether the data resides in Excel spreadsheets, Exchange Server Address Books, Active Directory servers, or tables in any ODBC-compliant database, the wizard can create new entities in a space plan model for the data it imports or store the entities as unplaced data in the Space and Category Explorer windows so you can place it when you’re ready.

If you enthusiastically populated your space plan drawing with shapes, the wizard can import external data into the shape data fields for those shapes. Otherwise, it goes ahead and creates new shapes to hold the data. For example, the Import Data Wizard can import department assignments into the Department shape data field for the existing Space shapes on the drawing page. On the other hand, faced with a multitude of people and assets to add, you can delegate the grunt work of creating and assigning Person, Computer, Printer, and Asset shapes to the space plan Space shapes to the Import Data Wizard.

Preparing Your Space Plan Data for Use in Visio

Regardless of the quantity of space and facilities data you use with Visio space plans, importing proceeds more smoothly when the data is set up the way Visio expects. The Import Data Wizard accepts data from a variety of sources, including Excel workbooks, Microsoft Active Directory directory services, Microsoft Exchange, and any ODBC-compliant data source, such as a Microsoft Access database. Conversely, the Space Plan Startup Wizard reads data only from Excel workbooks. To properly import data into a Visio space plan, follow these guidelines to set up your data:

- Assign unique identifiers—in the data source, include a field or column that uniquely identifies the spaces, people, and assets you want to add to your space plan. A key field, such as employee number or asset tag number, is necessary if you want to automatically update the space plan when data in your data source changes.
Using Visio for Architecture and Engineering

- **Include room numbers to assign resources to spaces** — For people and assets assigned to specific spaces, in the data source, include a field for room numbers. Room numbers in the data source must match the room numbers for spaces in your space plan. Leave the room number field blank if a person or asset isn’t assigned to a space. Use the same room number for each asset or resource assigned to a space.

  **NOTE** Visio stacks the shapes for all these resources within the same Space shape. If you want to see all the shapes on the drawing page, drag each shape away from the shapes underneath while keeping them within the Space shape.

  **NOTE** When a resource is assigned to a space number that doesn’t exist in the space plan, Visio places the resource in the Unplaced Data folder in the Explorer windows. You can create the spaces, if necessary, and manually place the resources in the appropriate spaces.

- **Identify buildings in a data field** — For data sources that include data for more than one building, include a field that represents the building name or number. You can specify which building’s data to import when you run the Import Data Wizard.

- **Include fields for other attributes** — For other data that you want to include in your space plan, set up additional fields, such as asset tag numbers, serial numbers, or maintenance dates. You can import this data into shape data associated with shapes.

## Using the Import Data Wizard

The Import Data Wizard does a lot, but it doesn’t take many steps to tell it what to do. To use the wizard to import facilities data and create shapes on a space plan, start by choosing Plan ➔ Import Data. Then, complete the steps described in the following sections.

**CAUTION** If you want the wizard to automatically assign people and assets to spaces, make sure your data source includes a field for room or space numbers. Also, verify that each Space shape on the Visio drawing includes a room or space number in its Name field. The easiest way to check for room numbers in Space shapes is to inspect the spaces in the Space Explorer window. If any space is named Space, you know that its Name property is blank.

**Tell the Wizard Where to Store the Imported Data**

In the first Import Data Wizard screen, you tell the wizard where to put the data you’re importing. Choose one of the following two options:

- To create shapes to hold the data you import, select the Into Shapes That I Will Manually Place option. Select a sub-option to either cascade the shapes on the page so you can drag them into position or store the items as Unplaced Data so you can drag them from the Explorer directly to their position on the drawing.
If you already have at least some shapes on the drawing, select the Into Shapes That Are Already on My Drawing option. Underneath that option, select a sub-option to add the data to the existing shape data or create new shapes on top of the existing shapes. For example, if you have Space shapes on the drawing and want to create People and Asset shapes in those spaces, select the Add As New Shapes On Top Of Existing Shapes option.

Click Next to proceed to the wizard screen for choosing the data source.

**Identify the Data Source**

In the What Is The Source Of The Data screen, in the Type drop-down list, select the type of data source that contains your facilities data (Excel, Active Directory, Exchange Server, or ODBC). The steps you take depend on the type of data source:

- **Excel** — Click Browse and then specify the path and file name for the file.
- **Active Directory** — Click Next to log into the server.
- **Exchange Server** — Click Next to log into the server.
- **ODBC** — Click Next to display an additional screen for selecting the data source, database file, and table within the database.

After specifying the data source, click Next to proceed to the wizard screen for specifying the data to import.

**Specify the Data to Import**

In the What Data Do You Want To Import screen, the way you specify the location of your data depends on the type of data source. For example, for a spreadsheet, from the Worksheet drop-down list, choose the name of the worksheet in the Excel workbook.

This screen includes two key check boxes: Include All Columns/Fields and Include All Rows/Records. If you leave these check boxes selected, you can skip to the next section, because Visio imports every record and every field in the data source. However, to choose the records and data fields to import, clear one or both of the check boxes. If you do so, the next screen that appears is your chance to tell the wizard what to import, as illustrated in Figure 28-5.
The Import Data Wizard can import all data in a data source or only some fields and records.

Click Next to proceed to the final section of the wizard.

**Configure the Shapes with Imported Data**

The final set of wizard screens that appear depend on whether you are importing data into existing shapes or adding shapes to the drawing as part of the import process. Here are the steps for both of these situations:
Creating shapes and importing data into them — If, in the very first step of the wizard, you chose the Into Shapes That I Will Manually Place option, do the following to configure the new shapes the wizard adds:

1. In the What Kind Of Shape Do You Want to Add to Your Drawing screen, Visio selects the Resource stencil by default. If the shapes you want to use are on another stencil in the Space Plan template, in the Stencil drop-down, choose the stencil or click Browse to choose from any Visio stencil.

2. Select the thumbnail of the shape you want and click Next.

3. To label or color-code the new shapes, specify the shape data you want to use to label or color by in the Label With and Color By drop-down list, respectively. Click Next.

4. On the next screen, specify the field in your data source with unique IDs, such as employee ID, Name, or ID. Visio adds these values to a shape data field in the new shapes and uses those values to update data when you use the Refresh Data command. Click Next.

Adding data to existing shapes — Because the shapes are already on the drawing, you don’t have to specify the type of shape to add. However, you do have to identify the shapes to receive data, by doing the following:

1. To label or color-code the new shapes, specify the shape data you want to use to label or color by in the Label With and Color By drop-down list, respectively. Click Next.

2. On the next screen, select the type of shape into which you want to import data. For example, you can choose all shapes or specify one type of shape. Click Next.

3. On the next screen, choose the shape data field that uniquely identifies the shapes on the drawing, for example, employee ID, Name, Room Number, or ID. Visio uses this field to match records in the data source with shapes on the drawing. When Visio finds a match, it adds the data to the shape’s data fields. Click Next.

4. On the next screen, choose the field in your data source that uniquely identifies the data records. When Visio finds a matching value in the shape data field and the data source identifier field, it adds the data to the shape’s shape data fields. Click Next.

On the final wizard screen, Visio displays a message that the Import Data Wizard is completing and lists the actions the wizard took, such as the number of shapes the wizard added or the number it updated with imported data. To finish and close the wizard, click Finish.

NOTE Just as you can with other shapes, you can manually add or change data in shapes by typing or selecting values in the Shape Data window. However, changing shape data does not change the corresponding data in your spreadsheet or database. Visio does not export data from your drawing back to your source data, so it’s important to make data changes in the external data source.
Refreshing Space Plan Data

When you import information into a space plan, you can create a connection between the data in the data source and the shapes on your space plan. After that connection is established, it’s a snap to keep your space plan current with any changes in your data source. For example, if employees move to other offices and the data source contains the new office numbers, refreshing data in the Visio drawing automatically shows the employees in their new spaces. When assets are sold or recycled and deleted from the data source, Visio removes them from the space plan as well. In addition, when the data source includes a new field such as maintenance data, refreshing the data adds that field to the shapes on drawing.

To refresh the data in a space plan, follow these steps:

1. Make sure that the data source hasn’t been deleted or moved.
2. If you haven’t done so already, use the Import Data Wizard and specify the field in your spreadsheet or database that contains unique identifiers.
3. Choose Plan ➪ Refresh Data. After the Refresh Data command processes the data, click the Import Data Report link to see a log of the changes the command made. Click OK.

Labeling Facilities Shapes

Labels on shapes make it much easier to find spaces and resources on a space plan, particularly when you use the Resources stencil shapes, because they are so similar in appearance. The Plan menu in the Space Plan template includes the Label Shapes command, which runs the Label Shapes add-on. To label Space and Resource shapes, follow these steps:

1. Select the shape or shapes you want to label and then choose Plan ➪ Label Shapes.
2. In the Label Shapes dialog box, in the Shape Type box choose <all selected shapes> to label the shapes you selected. If you want to label one type of shapes, select the shape name.
3. In the Label 1 box, select the shape data field to display as the first line of the shape’s label, as shown in Figure 28-6.
4. To display additional fields in subsequent lines in the text block, select the fields for Label 2, Label 3, and Label 4.
5. Click OK. Visio adds the label text blocks to the selected shapes.
The Label Shapes add-on can insert the values for up to four shape data fields into a text block on shapes.

Color-Coding Space Plans

Color-coding makes it easy to spot shapes on a drawing. For example, you can color-code Space shapes by assigned departments to quickly identify which spaces belong to which departments. If the same color is splashed randomly throughout a building, an office move to co-locate all the people in that department might be in order.

Although the new data graphics in Visio 2007 include an option to color-code shapes, the Space Plan template uses the Color By Values add-on to color-code shapes. Choose Plan ➤ Color By Values to color-code shapes.

To select the shapes you want to color-code, use one of the following methods:

- To color-code all shapes or all instances of one master, click the drawing page background to make sure nothing is selected.
- To color-code specific shapes, select only those shapes.
To run the Color By Values add-on, follow these steps:

1. Choose Plan ➪ Color By Values.
2. In the Color By drop-down list, select the shape data field by which you want to color-code the shapes. For example, choose Department to color spaces based on the departments assigned to them.
3. In the Shape Type list, select <all shapes>, <all selected shapes>, or the type of shape.
4. In the Range Type list, choose how to use colors to reflect values.
   - **Unique values** — This choice applies a different color to each unique value in the shape data, which is perfect for coloring shapes by department name.
   - **Discrete ranges** — Use this choice to use a different color for each range of values, such as 100 to 199, 200 to 299, and so on. This choice works well when you want to define the upper and lower limits of the ranges for each color.
   - **Continuous values** — This choice applies colors from low to high across the range of values in a field. For example, this choice would divide the range of square footage into equal ranges and apply a different color to each range.
5. In the Color field, select the colors you want to use.
   - **Unique values** — Click the color box for a value and choose the color you want to use. Repeat this step for each unique value.
   - **Discrete ranges** — Click the color box for a range and choose the color you want to use. Repeat this step for each range.
   - **Continuous values** — Click the first color to open the Color Ramp dialog box. By selecting a color in the Top Color and Bottom Color boxes, Visio creates gradations between the two colors for the range divisions it creates.
6. Visio adds a Legend shape to the drawing page showing the field used to color-code shapes and the correlation of color to values.

7. To modify the color-coding in your drawing, right-click the legend on the drawing page and from the shortcut menu, choose Edit Legend.

8. To update the color-coding to reflect changes to shape data, right-click the legend and choose Refresh Legend.

Finding and Moving Resources

The life of a facility manager is never boring with people quitting, new people being hired, and regular reorganizations thrown in for good measure. Naturally, as the locations of people and assets constantly change in a facility, so will your space plan. You can move people or assets in the Explorer window or move the corresponding shape on the drawing page. In addition, when you manage a large number of resources, you can use tools in Visio to quickly locate the resource you want.

To find resources in a space plan, use one of the following methods:

- **Using the Explorer windows** — In the Space or Category window, expand a space or category, right-click the person or asset you want to locate and, from the shortcut menu, choose Show. Visio displays the drawing page that contains the corresponding shape, selects the shape on the drawing page, and centers it in the drawing window.

- **Using the Find command** — If your space plan is crammed with so many resources that it’s hard to find the one you want even in the Explorer window, choose Edit ➤ Find. In the Find dialog box, in the Find What box, type text that is associated with the shape you’re looking for, such as its name. You can use text that appears on a shape, in shape data, or the shape name itself. Under Search In, select the locations you want to search and then click Find Next. The Find command finds the first shape containing the text you specified and highlights text within a shape or selects the shape if the text is found in a shape data field, shape name, or cell.

To move resources in a space plan, use one of the following methods:

- **Using the Explorer windows** — In the Space Explorer window, expand pages and space until you find the resource you want to move. Drag the icon for the resource onto a different space icon.

- **On the drawing page** — Select the shape that represents the resource you want to move and drag it into a different Space shape on the drawing page.
Generating Facilities Reports

Similar to other management callings, facilities management produces its fair share of reports. Visio Professional includes shapes for predefined reports, such as Door and Window Schedules that are useful in facilities management. In addition, Visio includes three specialized reports for space planning and facilities management:

- **Asset Report** — For each asset in a space plan, this report shows the asset type, its name, its manufacturer, and to whom it belongs. You can use this report as part of a facilities audit to ensure that resources are located where they should be or that the proper group has responsibility for the assets under their control.

- **Move** — This report shows where people are located.

- **Space Report** — This report shows the department, room number, space use, and area for each space in a plan.

To run a report, choose Data ➤ Reports. In the Reports dialog box, choose the report and click Run. To learn how to run or modify reports, see Chapter 10.

The easiest way to create one of these facilities management reports is to drag the corresponding report shape from the Resources stencil onto a drawing page. The shape uses the current report definition, gathers data from the shapes on the drawing, and displays the results in a shape on the page. To display other information, just modify the report definition before adding the shape to the page.

---

**Finding and Installing a Printer from a Space Plan**

You can use Visio space plans to locate printers. In addition, if Smart Tags are turned on, you can install that printer on computers right from the Visio plan. When others open the space plan, they can locate a printer that’s convenient. To set the printer as their default printer, they position the pointer over the Printer shape, click the Printer Smart Tag button and then, from the shortcut menu, choose Set As Default Printer. To see the documents in the printer’s queue, they choose Open Print Queue from the shortcut menu.

To set up a space plan to do this, follow these steps:

1. To turn Smart Tags on, choose Tools ➤ Options, select the View tab and make sure the Smart Tags check box is selected. Click OK.
2. Drag a Printer shape from the Resources stencil onto the space plan.
3. Position the pointer over the Printer shape. When the Smart Tag appears, click Configure Printer on the Smart Tag.
4. Choose either Find a Printer in the Directory if you use an Active directory or Browse for Printer to find the printer on the network.
5. In the Connect To Printer dialog box, select a printer, click OK, and then save the space plan drawing.
Summary

You can use Visio to plan space to varying levels of detail and then, after construction, manage the facilities and the people and assets within them. For high-level space planning, you can use Ink or the Space shapes available in both Visio Standard and Visio Professional. As you become more precise about the location and areas you’re planning, the Space Plan template provides specialized shapes and tools to help you.

The Space Plan template builds a model of a space plan in addition to a drawing. You can add, modify, and delete the elements of space plan directly on the drawing page or in either the Space Explorer or Category Explorer.

Because of the amount of data that space planning and facilities management requires, the Space Plan template provides the Space Plan Startup Wizard to jumpstart creating a space plan, the Import Data Wizard to import external data into Visio shape data, and the Refresh Data command to keep data in a space plan and an external source in synch.
Visio was never meant to be a substitute for a CAD program, such as AutoCAD. If you’re producing hard-core architectural or engineering drawings for large or complex projects, you’ll need every bit of functionality the CAD application provides — and even then, you’ll probably pine for features the CAD application doesn’t offer.

Where Visio shines when it comes to CAD drawings is ease of use. Suppose you’ve been working with an architect to remodel your house and now you want to arrange your furniture. The architect gave you the CAD drawings of the remodeled house, but you don’t know the first thing about CAD. What’s more, you don’t own CAD software. With Visio and CAD integration, you can bring the CAD drawings into Visio and use them as a backdrop for your interior decorating.

Taking a step back from using the finished architect’s drawings, Visio is also a handy review tool. When you have Visio, the architect can send the remodel plans in CAD format, and you can review them in Visio. If the palatial master bath looks like it will break your budget, you can let the architect know what you think by adding Ink shapes and text blocks to a separate layer to mark up and comment on the design.

When nothing but editing a CAD drawing will do, you can convert its contents into Visio shapes. Although this solution has its faults, including slow redraw, it’s invaluable if you must edit a CAD drawing and no longer have access to the CAD program that created it. Finally, Visio can export its shapes to a few CAD formats, which is helpful when you want to prototype a design in Visio and then send it to CAD for the detail work.
This chapter describes the different methods for working with CAD drawings using Visio and when to use each one. You'll also learn how to convert CAD drawings into Visio format and vice versa.

Understanding CAD and Visio Integration

Visio-CAD integration comes in four basic flavors:

- **Importing (inserting)** — This method is, by far, the most popular way to use a CAD drawing in Visio. The imported CAD drawing is an OLE object, visible on a Visio drawing page. You can snap to its contents as you would Visio shapes. However, the drawing isn't editable. Inserted drawings offer the following benefits:
  - You can view, but not edit, inserted CAD drawings, so that you can use the CAD drawing as a reference without worrying about it being changed inadvertently.
  - You can snap Visio shapes to the geometry in an inserted CAD drawing just as you snap to other Visio shapes, rulers, grids, and guides in Visio.
  - You can crop CAD drawings to show details for part of a Visio drawing.
  - Inserted CAD drawings open and redraw more quickly than converted CAD drawings.

**NOTE**

CAD drawings imported into Visio reside within an ActiveX control so they remain in their original file format. In Visio, you can modify the scale of the drawing and the layers that are visible.

**CAUTION**

Visio works with AutoCAD DWG and DXF files saved in AutoCAD 2002 or earlier (which represents AutoCAD 2000 file formats). If you use a newer version of AutoCAD, you must save your drawings to AutoCAD version 2002 or earlier before trying to import a CAD drawing.

- **Converting CAD drawings to Visio shapes** — Typically, the reason to convert a CAD drawing to Visio is to edit a CAD drawing when you don't have access to the program that created it. Because Visio and AutoCAD take dramatically different approaches to scaled drawings, working with converted CAD drawings in Visio tends to be slow and often problematic. The process of converting large CAD drawings to Visio format voraciously devours system memory, which sends the operating system paging memory out to disk and slows performance to a crawl. In addition, some CAD drawings won't convert at all. If you must edit a CAD drawing with Visio, keep the following points in mind:
  - CAD blocks and entities are mapped to the closest Visio shapes.
  - Quite often, lines and text blocks convert to separate shapes, reducing performance and sucking up every bit of memory your computer has to offer.
  - Converted CAD drawings don't look as good as inserted CAD drawings, because accuracy and some details are lost.
Microsoft recommends that you perform conversions in only one direction, because a CAD drawing converted to Visio loses any advanced features available only in the originating CAD program. If you subsequently reconvert the Visio drawing back into CAD, that additional information is gone.

- **Converting CAD symbol libraries to Visio masters on a stencil**—If you want to prototype plans in Visio, you can take advantage of predefined CAD objects by converting libraries of CAD blocks into Visio shapes on a custom stencil. Then, drawing in Visio is as simple as dragging and dropping your new masters onto the drawing page.

- **Exporting Visio drawings to CAD format**—If you create a sketch of a plan in Visio, you can export your Visio drawing to CAD format when it’s time to get serious about drawing. During export, Visio shapes convert to CAD entities, and, if you inserted CAD drawings, they go back to CAD format as they came in. You can save Visio drawings as DWG or DXF files.

Although you can export Visio drawings to the CAD format, for CAD users who want to review Visio drawings, the Visio Viewer is an easier solution for most other audiences, as described in Chapter 11.

If you’re familiar with CAD programs, Visio might leave you hungry for more. Conversely, as a Visio user, you might be frustrated by the complexity of most CAD programs. However, by understanding and appreciating their differences and similarities, you’ll know when to use which tool. Table 29-1 compares Visio and CAD features.

**TABLE 29-1**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Visio</th>
<th>CAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinate Systems</td>
<td>The Visio drawing page controls the coordinates you use, based on the drawing page size and scale you choose. For example, for a drawing page using feet for measurement units and a scale of 1:12, 1 inch on paper equals 1 foot in real-world measurements. To specify drawing size and scale, choose File ➪ Page Setup and select the Page Size and Drawing Scale tabs.</td>
<td>CAD programs often include two types of coordinate systems. Model space represents the true size of the objects in the model. Paper space applies a scale to the model so you can print or plot the model on paper. With this approach, you can create multiple paper spaces to display the same model space in different ways, for example, a site plan versus a building detail.</td>
</tr>
</tbody>
</table>

*continued*
TABLE 29-1  (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Visio</th>
<th>CAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Units</td>
<td>For unscaled drawings, drawing units are simply the units in which you define the drawing page, such as inches. For scaled drawings, the drawing units, which you see on the ruler, are the real-world units. Measurement units are the units that Visio uses to dimension shapes, which you choose in the Page Setup dialog box on the Page Properties tab. You can select from U.S. units, metric units, publishing units, and even time-based units.</td>
<td>Units represent the real-world units for the model coordinate system, but aren’t set to specific units such as feet or meters.</td>
</tr>
<tr>
<td>Scale</td>
<td>Drawing scale is the ratio of real-world measurements on the drawing page to the units on the printer paper. Every shape on a drawing page is drawn at the same scale. When you insert or convert a CAD drawing, Visio inserts the CAD drawing at the same scale as the drawing page, whether or not the CAD drawing fits on the drawing page.</td>
<td>In paper space, CAD creates views of your model in which each view can use a different scale. You can use one scale for an entire floor plan and another for a construction detail. Unlike Visio, you can compose a print or plot with multiple views, each using a different scale.</td>
</tr>
<tr>
<td>Layers</td>
<td>Visio layers categorize shapes and you can assign the same shapes to more than one layer. Visio layers don’t control stacking order. You can specify attributes such as color, visibility, printability, and whether shapes are editable.</td>
<td>CAD layers also categorize shapes so you can control their attributes. However, unlike Visio, CAD layers can also control the order in which CAD objects appear and CAD objects can only belong to one layer.</td>
</tr>
<tr>
<td>Objects</td>
<td>Shapes</td>
<td>Blocks</td>
</tr>
</tbody>
</table>

**Displaying CAD Drawings in Visio**

Visio is ideal as a viewing tool for CAD drawings. It’s easy to use and includes tools, such as markup and Ink, that even the most sophisticated CAD programs might not offer. Of all the methods for working with CAD drawings in Visio, inserting them into Visio drawings is the preferred way to go. Your CAD drawings look better, Visio responds faster; and you can still control many aspects of inserted drawings. With inserted CAD drawings, you can perform the following tasks:

- Use Visio to review CAD drawings produced by someone else, adding comments with Visio shapes, text, Ink, or markup on a separate Visio layer.
- Insert CAD drawings as backgrounds for Visio drawings. For example, if you want to use Visio to quickly prototype different office layouts, you can insert a CAD floor plan into your drawing as a reference and add Visio Furniture and Equipment shapes over it.
within Visio, you can crop or pan the CAD drawing to change the area that appears as a background, or you can hide or show layers. However, you can’t edit the CAD geometry.

- Insert CAD drawings as details. For example, you can insert a CAD drawing that shows a highly detailed structural connection on a Visio drawing of an entire floor.

**Reviewing CAD Drawings in Visio**

If viewing a CAD drawing is your only goal and you don’t plan to add Visio shapes or even markup on top of it, you don’t have to insert the CAD drawing into a Visio drawing. Just open the CAD drawing directly by following these steps:

1. Choose File ➤ Open.
2. In the Files of Type box, select AutoCAD Drawing.
3. Navigate to the folder that contains the file you want to open, select the file, and click Open. Visio creates a new drawing file and one drawing page, inserts the CAD drawing onto the page, and sets the Visio measurement units and drawing scale to the units and scale of the CAD drawing.
4. To see when the CAD drawing was last updated — for example, to check that you have the latest version of the drawing — right-click the inserted CAD drawing and, from the shortcut menu, choose Data ➤ Shape Data. The Last Updated box shows the latest modification data, and the CAD File Name property shows the original file name of the CAD drawing.
5. After you open the drawing, you can crop, resize, rescale, or reposition the drawing, as well as hide or show its layers and change layer colors, as described in other sections in this chapter.

**NOTE** Image files embedded in DWG files don’t appear when you insert the CAD drawing into Visio. However, they will appear if you convert the drawing to Visio shapes. If you have no reason to convert the CAD drawing to Visio, you can embed the image files in the Visio drawing directly using the methods described in Chapter 8.

**Inserting CAD Drawings into Visio**

When inserting a CAD drawing from a DWG or DXF file into Visio (available in both Standard and Professional versions), the Visio drawing assumes the last saved spatial view of the CAD drawing, either in model space or paper space. By using a CAD drawing saved in model space, you have more control over the CAD drawing after it’s inserted into Visio. For example, with CAD drawings saved in model space, you can change the CAD drawing’s scale in Visio. In addition, panning and resizing in Visio is faster when you use model space drawings. To insert a CAD drawing into a Visio drawing, follow these steps:

1. Open the Visio drawing file and the page that you want to contain the CAD drawing.
2. Choose Insert ➤ CAD Drawing. In the Insert AutoCAD Drawing dialog box, navigate to the folder that contains the CAD drawing, select the DWG or DXF file you want to insert, and click Open.
The CAD file name must end in DWG or DXF or it won’t appear in the Insert AutoCAD Drawing dialog box.

3. In the CAD Drawing Properties dialog box, Visio automatically sets the scale to the Visio page scale and displays all the CAD layers. If you have specific requirements, choose the settings you want, as described in other sections of this chapter. The preview pane shows the size of the CAD drawing compared to the Visio drawing page, as shown in Figure 29-1. If the CAD drawing doesn’t fit on the Visio drawing page, the best solutions are to either change the size of the Visio paper or change the Visio drawing scale.

FIGURE 29-1
Visio sets the CAD drawing scale to match the Visio drawing scale so CAD objects and Visio shapes appear at comparable sizes.

4. Click OK. The CAD drawing appears on the Visio drawing page.

Displaying CAD Layers in Visio
Although CAD drawings are typically teeming with layers, each inserted CAD drawing is assigned to only one Visio layer, named CAD Drawing. You might think that the CAD drawing layers are a lost cause, but within that inserted CAD drawing, you still can specify which CAD layers are visible, along with the color and line weight for the objects on each layer. Whether you’ve just inserted the CAD drawing or are working on the Visio drawing at any time afterward, right-click the CAD drawing on the Visio drawing page and, from the shortcut menu, choose CAD Drawing Object Properties. Select the Layer tab and then use one of the following methods:
Working with External File References

When you insert or convert a CAD drawing that references external files, Visio tries to open those external files as well. Visio looks for external reference files in a folder with the same path as the one used when the file was originally linked or in the same folder as the Visio drawing. Before you insert a CAD drawing — or when you receive a message that Visio can’t find the externally linked files, be sure to place any external files in the same folder as your Visio drawing or create a folder structure that mirrors the original used by the CAD drawing.

- **Visibility** — To toggle the visibility of a layer, click the Visible field for the layer you want to toggle (or, select the layer and then click the Set Visibility button).
- **Color** — To specify the color of a layer, click the Color field for the layer you want to tint (or select the layer and then click Set Color). On the Standard tab, click a color cell, or select the Custom tab and specify the color you want. Click OK.
- **Line Weight** — To specify the line weight for lines on a layer, click the Line Weight field for the layer you want to modify (or select the layer and then click Set Line Weight). Type the line weight in points and then click OK.

Modifying Inserted CAD Drawings

Although you can’t edit the CAD drawings you insert into Visio, you can modify them in several ways. You can change units and scale, for example to create a thumbnail image of the floor plan. If you want to show specific portions of an inserted CAD drawing, you can crop, pan, move, or modify the visibility of layers in the CAD drawing. You can drop Visio shapes on top of the CAD drawing and even position Visio shapes by snapping to the geometry of the inserted drawing.

**TIP** If you want to edit or delete individual objects in an inserted CAD drawing, convert only the layers containing those objects to Visio shapes and then make the changes you want.

Modifying Units and Scale

When you insert a CAD drawing into a Visio drawing, Visio sets the CAD drawing scale to the Visio page scale, which means that Visio shapes and CAD objects with the same dimensions automatically appear at the same size in Visio. Even when you match the drawing scales when you insert a CAD drawing, you can change the CAD drawing scale by dragging the border of the inserted drawing. If you use a scale other than the Visio page scale, the CAD drawing becomes a sizable image rather than a scaled drawing. This is helpful if you don’t plan to overlay Visio shapes over the CAD drawing, for example, when you insert the CAD drawing as a thumbnail image of the overall building on a Visio drawing that lays out the office space in one wing.
Coordinating CAD Units with Visio Measurement Units

CAD drawings don’t use pre-set drawing units. In the CAD world, a drawing unit can represent any unit—from a centimeter to an inch, or even a mile. When you insert a CAD drawing into a Visio drawing, Visio interprets CAD drawing units as Visio measurement units, which might be incorrect, especially if you insert a metric CAD drawing into a Visio drawing based on U.S. drawing units. To change the measurement unit for a CAD drawing, follow these steps:

1. To check the measurement units for the drawing page in which the CAD drawing is inserted, select the drawing page tab and then choose File ➪ Page Setup.
2. Select the Page Properties tab and check the value in the Measurement Units box. Click OK. If you prefer to change Visio units, change the value for Measurement Units here.
3. On the Visio drawing page, right-click the inserted CAD drawing and, from the shortcut menu, choose CAD Drawing Object ➪ Properties. On the General tab, in the CAD Drawing Units drop-down list, select the units that match the Visio measurement units. For example, if the Visio drawing uses feet and inches, select Feet in the CAD Drawing Units list.
4. Click OK.

Modifying Drawing Scales

CAD drawings often represent very large areas, such as the sprawling enclosure of a shopping mall. When you insert CAD drawings like this into Visio drawings, they might not fit on the Visio drawing page. You can change the Visio drawing scale and the CAD drawing scale to one that squeezes the CAD drawing onto the page. If you haven’t drawn any Visio shapes yet, changing the Visio drawing page size (and possibly the scales) is another option. To change drawing scales, follow these steps:

1. If you want to change the Visio drawing scale, choose File ➪ Page Setup and select the Drawing Scale tab. For example, you can change the Visio drawing scale to fit the CAD drawing on the Visio drawing page.
2. To use a standard architectural or engineering scale, select the Pre-Defined Scale option, select the type of scale you want, and then select the scale you want to use. Click OK.

If you want to use a custom scale, select the Custom Scale option and then enter a paper dimension in the first box and the real-world distance it represents in the second box.

3. To change the drawing scale for the inserted CAD drawing, right-click the inserted CAD drawing and, from the shortcut menu, choose CAD Drawing Object ➪ Properties.
4. Select the General tab, and select the scale using one of the following methods:

- **Match CAD and Visio scale** — By default, Visio selects the Pre-defined Scale option and Page Scale in the drop-down list. This sets the CAD drawing to the same scale as the Visio drawing page scale and shows Visio shapes and CAD objects at the same size.

- **Use industry-standard scale** — If you are only reviewing an inserted drawing and won’t add Visio shapes on top of it, select the Pre-defined Scale option, in the drop-down list, select the type of scale you want to use, and then the specific scale.

- **Define a custom scale** — Select the Custom Scale option and then enter a paper dimension in the first box and the real-world distance it represents in the second box.

5. Click Apply and then check the preview of the CAD Drawing and the Visio drawing page (shown in Figure 29-1) to make sure that the CAD drawing still fits on the Visio drawing page. If the CAD drawing doesn’t fit, either change the Visio drawing size or change the scales you use.

6. When the inserted drawing is scaled the way you want, click OK.

NOTE You can't change the scale of an inserted DWG drawing saved in paper space.

### Protecting Inserted CAD Drawings

By default, Visio protects the CAD drawings you insert from deletion, resizing, and repositioning. When a CAD drawing is locked, you can't inadvertently move it, reposition it, or delete it as you work on Visio shapes overlaid on top of it. However, if you do want to reposition the CAD drawing or change it in other ways, first you must unlock the drawing from within the CAD Drawing Properties dialog box. To unlock an inserted CAD drawing, follow these steps:

1. Right-click the inserted CAD drawing and, from the shortcut menu, choose CAD Drawing Object Properties.

2. Select the General tab and clear the Lock Size And Position check box and the Lock Against Deletion check box.

3. Click OK.

4. After you’ve completed the change to the CAD drawing, reopen the Cad Drawing Properties dialog box, and select the Lock Size and Position check box and the Lock Against Deletion check box.

In addition to the locking you can do with CAD Drawing Properties, you can also lock the Visio layer on which the CAD drawing is inserted. Although this technique mainly has the same effect as locking the CAD Drawing properties, it has the added advantage of preventing the drawing from moving when you pan using the Crop tool.
Positioning and Resizing Inserted CAD Drawings

Sometimes, you want to show only a portion of a CAD drawing, for example, the section of a floor plan for the offices you are laying out in Visio. Likewise, a CAD drawing smack in the middle of the drawing page isn’t what you want, for example, when you offset the floor plan on the page to make room for notes on one side. What resizing and repositioning in Visio does depends on the tool you use, as described in Table 29-2. You can reposition or resize the entire CAD drawing. You can also crop the CAD drawing, reducing the CAD drawing border so that only a portion of the drawing appears. Panning within a cropped border changes the portion of the CAD drawing that you see, as shown in Figure 29-2.

TABLE 29-2

<table>
<thead>
<tr>
<th>Visio Tool</th>
<th>Positioning</th>
<th>Resizing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointer Tool</td>
<td>When the Pointer tool is active, move the entire drawing to a new location by dragging the inserted CAD drawing.</td>
<td>When the Pointer tool is active, change the size of the CAD drawing on the Visio drawing page (and its corresponding CAD drawing scale) by dragging a selection handle.</td>
</tr>
<tr>
<td>Crop Tool</td>
<td>To pan the area of the CAD drawing that appears within the CAD drawing border, on the Picture toolbar, click the Crop tool, click inside the CAD drawing border, and drag the Hand icon to a new location.</td>
<td>To crop the CAD drawing border so only a portion of the CAD drawing appears, right-click the CAD drawing and, from the shortcut menu, choose Crop Tool. Then drag a selection handle on the CAD drawing border until it’s the size you want. Click the Pointer tool to turn off the Crop tool.</td>
</tr>
<tr>
<td>Drawing Scale</td>
<td>Does not apply</td>
<td>Change the size of a CAD drawing by specifying a different scale in the CAD Drawing Properties dialog box. This is more precise than dragging the inserted CAD drawing’s selection handles.</td>
</tr>
</tbody>
</table>

Finding the Invisible CAD Drawing

Placing an object far from the main drawing action is an all-too-common error in CAD. It’s easy to apply a CAD command incorrectly or specify the wrong dimension. When you don’t see the object where you expect it, you might just add it again. By doing this, you end up with one object where it’s supposed to be, but another out in space somewhere.

If you can’t see the contents of your CAD drawing in Visio, go back to the original CAD application and zoom to the drawing extents. If you see a tiny speck of color off in one corner, chances are good that the drawing has some wayward objects. If an inserted drawing balloons past the edges of the Visio drawing page, the best solution is to correct this issue in your CAD drawing. Open the drawing in the CAD program, locate and delete the objects that are misplaced, and resave the drawing. Then, insert the corrected drawing in Visio.
Before you attempt to reposition or resize an inserted CAD drawing, make sure that the drawing is unlocked. To confirm that it is unlocked, right-click the drawing choose CAD Drawing Object Properties, and then clear the Lock Size and Position check box and the Lock Against Deletion check box. To confirm that the Visio layer into which the CAD drawing is inserted is also unlocked, choose View Layer Properties and ensure that the Lock field for the CAD Drawing layer is cleared.
When you’ve completed repositioning and resizing the object, lock the drawing so that you don’t accidentally move or resize it as you continue your work.

**Editing CAD Drawings in Visio**

Converting CAD drawings to the Visio format isn’t recommended, but sometimes, it’s the only solution. For example, you have a CAD drawing that you received from an architect and absolutely must make changes to it before a presentation Monday morning. After the CAD drawing is converted to Visio shapes, you can use Visio tools to modify the contents the way you want.

If you do convert a drawing to make changes, don’t convert the modified drawing back into the CAD format. This two-way conversion can reduce the quality of the drawing. Instead, ask the originator of the drawing to use the CAD program to make the same changes you did.

**The Disadvantages of CAD Conversion**

CAD and Visio formats differ significantly, and converting a CAD drawing into the Visio format highlights those differences. CAD drawings can contain thousands, even hundreds of thousands, of objects, each of which belongs to one of the CAD layers. When you convert a CAD drawing into the Visio format, Visio converts those CAD objects into Visio shapes and assigns them to layers using the layer names contained in the source CAD drawing. Visio doesn’t always recognize all the objects that represent the same item, such as an office chair, which should convert into the same Visio shape. The result—a converted CAD drawing with thousands of different shapes, each stored separately in the Visio drawing file. This glut of unique Visio shapes raises two issues with converted CAD drawings:

- **Slow response time**—Visio must sort through thousands of shapes and perform tremendous amounts of processing for the simplest actions, such as selecting all the shapes and repositioning them. Even relatively small converted drawings generate a noticeable delay in redraws or completion of commands.

- **Large file size**—When you use Visio masters, Visio stores the definition of the master only once and uses instances of the master to show shapes on the drawing page. When you convert CAD objects into unique shapes, Visio stores each shape definition separately, greatly increasing the Visio file size. For example, a DWG file that consumes 850KB of space might require 10MB of space after it’s converted into Visio shapes.

When you convert a CAD drawing, you convert the last saved view of that drawing, which might have been saved in model space or paper space. Converting a drawing saved in model space converts all the objects and text on the layers you select into Visio shapes. However, when you convert a drawing saved in paper space, Visio converts only the objects wholly contained within the paper space viewport into Visio shapes, converting anything partially contained in the viewport into lines.
Converting CAD Drawings to Visio Format

Because of the quantity of data that CAD drawings often contain, the Visio conversion tool helps you limit what you convert by specifying which CAD layers to convert. Even so, it's a good idea to eliminate unused layers, blocks, linetypes, and other types of CAD objects from the CAD drawing before you begin conversion. To convert a CAD drawing into Visio shapes, follow these steps:

1. Insert the CAD drawing into Visio as described in the section “Inserting CAD Drawings into Visio,” earlier in this chapter.
2. Right-click the CAD drawing and, from the shortcut menu, choose CAD Drawing Object ➪ Convert.
3. To ensure that the conversion proceeds as fast as possible and the resulting file is a manageable size, in the Convert CAD Object dialog box, click Unselect All to ensure that no layers are selected.
4. In the Convert CAD Object dialog box, select only the check boxes for the layers you want to convert to Visio shapes.
5. To specify additional options for the conversion, click Advanced. A second Convert CAD Object dialog box opens with options for how you want to convert the CAD drawing.
6. In the second Convert CAD Object dialog box, shown in Figure 29-3, choose conversion options:
   - **Delete Selected DWG Layers** — For each layer you select for conversion, this option tells Visio to delete the layers from the original inserted CAD drawing, which means you won’t see shapes duplicated between Visio and the background CAD drawing. Unconverted layers remain as part of the display-only inserted CAD drawing.
   - **Hide Selected DWG Layers** — For each layer you select for conversion, Visio hides the original CAD layers. You won’t see duplication, but the original CAD objects are still there in case you need them.
   - **Delete All DWG Layers** — Visio converts the selected layers into Visio shapes and then deletes the entire inserted CAD drawing.
   - **Convert Into Visio Dimension Shapes** — This option converts CAD dimensions into Visio Dimension shapes, which means those shapes will recalculate dimensions as you edit the plan shapes.
   - **Convert Into Lines and Text** — This option converts CAD dimensions into Visio drawing elements, which won’t adjust as you edit the drawing.
   - **Do Not Convert Hatch Patterns Into Visio Shapes** — Choosing this option dramatically reduces the number of shapes in the converted drawing but also means no hatching appears in the converted drawing.
   - **Convert Every Hatch Line Into A Visio Shape** — The conversion processes hatching, but also creates a separate shape for every line of hatching. A better alternative is to convert the drawing without hatching and use Visio tools to reintroduce the hatching you want.
7. Click OK to close the Convert CAD Object dialog box and then click OK to convert the CAD drawing into Visio shapes. Depending on the size and detail in your CAD drawing, this process can take some time. A progress bar shows you how much of the conversion process is complete.

8. After you've converted the layers you want, be sure to lock the remainder of the inserted CAD drawing, as described earlier in this chapter.

9. Save the Visio drawing.

**TIP**

When blocks in a CAD drawing overlap, the resulting Visio shapes in the converted drawing overlap as well, but they might not appear in the correct order. To correct the stacking order in which converted Visio shapes appear, choose Shape, and then choose either Bring to Front, Bring Forward, Send to Back, or Send Backward.
Converting Multiple CAD Drawings

If you want to convert several CAD drawings, you can use the Convert CAD Drawings add-on. However, this add-on converts each CAD drawing into a separate Visio drawing file and converts every layer in each CAD drawing. If you need more control over the conversion process, convert each drawing separately using the Convert command. To use the Convert CAD Drawings add-on, follow these steps:

1. Copy or move all the files you want to convert into one folder.
3. In the Convert CAD Drawings dialog box, navigate to the folder that contains the drawings you want to convert, select all the files you want to convert, and then click Open.
4. After Visio converts the CAD files into Visio drawing files, save each of the converted files by choosing File ➪ Save. Although Visio opens the Save As dialog box, the Save As Type option is set to Drawing (*.vsd) for a Visio drawing file. Type the name for the new file and click Save.

Creating Stencils from CAD Libraries

When you work in Visio, you don't have to forego the symbols available to you in your CAD application. Symbol libraries are nothing more than regular DWG files that contain library objects. You can convert the symbols in those DWG files into Visio masters and store them on a stencil to drag and drop as you would any other Visio shape. When you convert a symbol library, each block becomes a Visio master, named based on the name of the original block used to create it. Block attributes are converted into Visio shape data and are stored with the master on the stencil. No matter how many symbol libraries you convert at once, Visio places the new masters on one new stencil. Block attributes become Visio shape data stored in the master on the stencil.

To convert CAD libraries to a Visio stencil, follow these steps:

2. In the Convert CAD Library dialog box, select all the DWG files for the libraries you want to convert and then click Open. The add-on converts each block in the selected DWG files to a master and places them on a new stencil.
3. To save the stencil, right-click its title bar and, from the shortcut menu, click Save As. In the Save As dialog box, type a name for the stencil and then click Save.
Converting Visio Drawings to CAD Format

In some circumstances, you might want to save a Visio drawing to CAD format. For example, suppose you’ve prototyped a plan in Visio and don’t want to redraw it in your CAD application. It’s easy to save Visio files as DWG or DXF files. You simply choose File ➪ Save As, in the Save as Type dropdown list, select either AutoCAD Drawing or AutoCAD Interchange, and then click Save. However, you must save each page in a multipage Visio file separately. Metafiles, such as Ink objects, inserted in Visio files are not supported when you save a Visio file as an AutoCAD drawing. Visio maps Visio entities to the most representative CAD element in the DWG or DXF file formats.

Visio drawings are saved as DWG or DXF files with fills and hatches turned off. You can turn fills and hatches back on in AutoCAD by setting the FILLMODE system variable to 1 and then using the REGEN command to regenerate the drawing.

Summary

Working with CAD drawings and Visio drawings can go several ways. When you don’t need to edit CAD drawings, inserting CAD drawings as OLE objects into Visio drawings is easy and relatively quick, but you can still move and resize the CAD drawings on the Visio drawing page, and modify settings such as scale and visibility. Editing CAD drawings in Visio is possible by converting the CAD drawings to Visio shapes, but the slow performance and potential conversion problems make this a last resort. You can convert CAD symbol libraries to Visio drawings and stencils, if you want to build Visio drawings with the symbols you use in your CAD application. And, finally, converting Visio drawings to the CAD format is as easy as using Save As with one of the AutoCAD file formats.
Engineering drawings can be complex, but building them doesn’t have to be. The templates that Visio Professional provides for engineering disciplines include many of the shapes and symbols you need to prepare mechanical, electrical, and process engineering drawings, diagrams, and schematics. (Visio Standard doesn’t include any of the engineering templates.)

What’s more, you can use basic Visio techniques, such as drag and drop, shape text blocks, snap and glue, and shape data, to construct and fine-tune your engineering drawings. Although you can drag shapes from Electrical Engineering, Mechanical Engineering, and Process Engineering stencils onto a drawing page, with basic Visio tools, you can position those shapes to the precise tolerances required in parts and assembly diagrams. Connectors and glue define the relationships conveyed in process flow diagrams.

Engineering stencils include hundreds of configurable shapes that make it easy to produce the documents you want. In addition, the Process Engineering template includes tools that help you build a process engineering model. You can create components to track the elements of your model and view your model on a Visio drawing or in outline form.

This chapter shows you how to create mechanical and electrical engineering diagrams and schematics. It also describes how to build process engineering models and create process engineering diagrams. In addition, you will learn how to use components to add data to the shapes on your engineering drawings, tag and number components, and generate component lists and bills of materials.

IN THIS CHAPTER

- Exploring the engineering templates
- Using basic Visio techniques in engineering drawings
- Creating mechanical engineering drawings
- Creating electrical engineering drawings
- Viewing process engineering models
- Creating P&ID and PFD drawings
- Associating shapes with components
- Working with component data
- Tagging and numbering components
- Generating process engineering reports
Exploring the Visio Engineering Templates

Visio Professional includes templates for mechanical, electrical, and process engineering drawings and schematics. The Mechanical Engineering and Electrical Engineering templates include stencils of shapes that make it easy to assemble drawings. The Process Engineering templates go one better with tools to build a model and manage components. Unlike the separate engineering categories in Visio 2003, all the engineering templates in Visio 2007 are lumped into the Engineering category. Nevertheless, when you select File ➪ New or use the Getting Started pane, here’s how the templates you see correspond to engineering disciplines:

- **Mechanical Engineering**
  - **Fluid Power** — Document designs for hydraulic or pneumatic controls, fluid and valve assemblies, fluid power equipment, and flow paths through systems.
  - **Part and Assembly Drawing** — Produce drawings and specifications that show the construction of parts, how to assemble equipment, or how machine parts fit together.

- **Electrical Engineering**
  - **Basic Electrical** — Produce wiring diagrams, electrical schematics, or one-line diagrams.
  - **Circuits and Logic** — Document integrated circuit designs, printed circuit boards, or digital or analog transmission paths.
  - **Industrial Control Systems** — Produce drawings of industrial control systems and power systems.
  - **Systems** — Represent components and relationships between electrical devices, particularly for large-scale systems such as utility infrastructure.

- **Process Engineering**
  - **Piping and Instrumentation Diagram** — Design and document industrial process equipment and pipelines.
  - **Process Flow Diagram** — Represent piping and distribution systems and processes.

Using Basic Visio Techniques in Engineering Drawings

In many cases, you can produce complex engineering drawings with nothing more than basic Visio tools. Consider the following Visio tools for building engineering drawings:

- **Drag and drop** — Drag shapes from Engineering stencils onto drawing pages.
- **Connectors and the Connector tool** — Drag connectors onto a page and glue the ends to Engineering shapes or use the Connector tool to draw the connector you want between shapes. Engineering shapes aren’t set up to work with AutoConnect.
Working with Mechanical Engineering Drawings

You probably wouldn’t want to rely on the Parts and Assembly Drawing template to produce complex mechanical drawings every day, but it does provide basic tools for creating detailed part specifications or showing how pieces of equipment are assembled. The Fluid Power template is intended to document hydraulic or pneumatic power systems, flow control, and fluid power schematics and assemblies. Neither template includes specialized menus or toolbars, but they open several stencils with specialized shapes—many of which include control handles or shortcut commands for configuration.

Drawing Parts and Assemblies

To manufacture mechanical parts, you need drawings that specify a part’s dimensions, edges, planes, and curves. To assemble separate parts into a functional whole, you need instructions that show how the parts fit together. The Visio Parts and Assembly Drawing template includes masters that help you construct the geometric shapes found frequently on part and assembly drawings.
To create a part and assembly drawing, choose File ➪ New ➪ Engineering ➪ Part and Assembly Drawing. The US Units template creates a new ANSI B-size (17 inches by 11 inches) drawing in landscape orientation using a mechanical engineering one-quarter scale (shapes appear on the page at one-fourth of their actual size). The Metric template sets the paper to A4 landscape and the scale to 1:10. In addition, the following stencils open:

- Stencils in the Engineering stencil category:
  - Fasteners 1 — Nuts and bolts
  - Fasteners 2 — Rivets and washers
  - Geometric Dimensioning and Tolerances — Symbols used to show dimensioning origins and tolerances
  - Springs and Bearings — Shapes for springs and different types of bearing conditions
  - Welding Symbols — Standard shapes that indicate different types of welds

- Stencils in the Visio Extras stencil category:
  - Annotations — Annotation shapes for callouts, text blocks, north arrows, reference and section indicators, and drawing scale symbols.
  - Drawing Tool Shapes — Geometric shapes often used for parts and assemblies, including circle tangents, perpendicular lines, triangles, and rounded rectangles. Try these shapes before diving into Shape Operation commands for less common geometries.
  - Dimensioning-Engineering — Dimensioning shapes that use standard engineering dimension styles for linear and radial dimensions.
  - Title Blocks — Frames, tables, title blocks, and revision blocks.

Using Geometric Shortcuts

The shapes on the Drawing Tool Shapes stencil, shown in Figure 30-1, are quite fascinating. Unlike many other shapes that represent specific elements, these shapes simplify drawing geometric constructions — without resorting to basic Visio drawing tools or Shape Operation commands. The basic drawing tools provide only one way to construct rectangles and circles. The Drawing Tool Shapes stencil offers shapes for drawing circles using four different sets of data and four different types of rectangles. For example, you can create circles by specifying the circle diameter, the circle radius and one point on the circumference, or by using three points on the circumference. In addition to handles that you can drag, some shapes have shortcut menus that offer other constructions. For example, the Sector-graphical shape shortcut menu includes the Show Complementary Sector command, which switches a pie slice to the rest of the pie.
The shapes on the Drawing Tool Shapes stencil provide shortcuts for drawing many types of common geometric constructions.

Measure shapes — In the stencil, these masters look like measuring tapes. Drag a shape, such as Measure Tool, Horizontal Measure, or Vertical Measure, onto a page and glue it to the shape from which you want to measure. As you drag the green selection handle around, the text block shows the distance from the glued point in the set measurement units.

Circle Tangents and Arc Tangents — These shapes are ideal for drawing systems comprised of belts and wheels. The control handles at either end of the Arc Tangent shape adjust the radius at the corresponding end of the shape. Dragging the yellow control handle on the Circle Tangent shape changes the length of the tangent line and the position of the end points while keeping the line tangent to the circle.

To create linkages for belt systems, for example, to connect one mechanical cam to another, drag an Arc Tangents shape onto the drawing page to represent the first cam, then drag another Arc Tangents shape onto the page and glue one of its connection points to the first Arc Tangents shape.
Part V  Using Visio for Architecture and Engineering

- **Rounded Rectangle** — Use this shape to quickly draw process storage tanks. Change the roundness of the corners by dragging the control handle.

  **NOTE**  
  For shapes specifically for tanks, open the Equipment–Vessels stencil in the Engineering ‥ Process Engineering category.

- **Sector-graphical and Arc-graphical** — The Sector-graphical shape is a pie slice with selection handles for changing the radius, origin, and rotation of the slice, and a control handle that modifies the angle circumscribed by the slice. The Arc-graphical shape is an arc shape that works the same way as the Sector-graphical shape.

- **Sector-numeric and Arc-numeric** — The selection handles and control handles determine the radius and origin for the sector or arc. Instead of dragging a control handle to define the angle circumscribed by the slice or arc, select the shape and type the number of degrees for the angle, even though there’s no visual indicator that tells you that.

- **Triangle shapes** — These triangle shapes take you back to those halcyon days of geometry class and Pythagoras. In addition to constructing triangles with different sets of data you can adjust the angles in the Right Triangle: Angle, Hypotenuse shape by selecting the shape and typing the angle you want.

- **Multigon shapes** — To draw polygons with different numbers of sides, drag one of these shapes onto the drawing page, right-click the shape, and then, from the shortcut menu, choose the polygon you want — from the triangle that appears initially up to an octagon.

**Creating Springs, Bearings, and Fasteners**
Springs, bearings, and fasteners come in many standard shapes and sizes — too many to include one of each on the Mechanical Engineering stencils. To provide the plethora of sizes you might need, most of these shapes include shape data to configure shape dimensions. When you modify the value in a shape data field, such as the Number of Coils for a Helical Spring shape, the shape morphs accordingly. In some shapes, you can specify one dimension and let Visio adjust the other dimensions based on industry standards or you can set all the dimensions exactly the way you want. Although these shapes are locked so you can’t resize them inadvertently, you can unlock and display the shape handles so you can use them to resize the shapes. The following list includes some of the commands that appear on shape shortcut menus, depending on which shape you right-click:

- **Set Standard Sizes** — Choose this command on a shortcut menu to modify the thread diameter in the Shape Data dialog box. Visio adjusts the other dimensions for the shape to industry-standard lengths.

- **Set Dimensions** — Modify one or more of the dimensions in the Shape Data dialog box to configure the shape the way you want.

- **Resize with Handles** — Display the selection handles on a shape so you can resize it by dragging.
Creating Welding Symbols

As you probably expect, the symbols on the Welding Symbols stencil show the locations and types of welds on a drawing. Although the Visio welding shapes faithfully duplicate the appearance of industry standard welding symbols, you need to know what kind of welds are required if you want your metal pieces to hold together.

To add a weld to a drawing, follow these steps:

1. Drag one of the Arrow shapes (Arrow, Arrow with Bend, or Additional Arrow) from the Welding Symbols stencil onto the drawing page and position it so that the arrowhead points to the weld joint.
2. To specify additional weld information, right-click the arrow shape and, from the shortcut menu, choose Show All Around Circle and/or Show Tail.
3. To add symbols to specify the type of weld, follow these steps:
   a. Double-click the Arrow shape on the drawing page to open the shape's group window.
   b. Drag symbols that represent different types of welds, such as V-groove, from the stencil onto the Arrow shape in the group window.
   c. To annotate the weld, drag Annotation shapes into the group window and edit the text. You can glue Welding Symbol shapes and Annotation shapes to the guides in the group window to keep symbols positioned correctly when you resize the Arrow shape.
4. To return to the drawing page, click the Close button in the group window.

Annotating Dimensions and Tolerances

Part and assembly drawings are typically awash with dimensions. Between the Dimensioning-Engineering stencil and the Geometric Dimensioning and Tolerancing stencil, Visio engineering templates offer shapes for adding datum points and dimensions.

Dimension shapes include control handles you can drag to define the distance to measure as well as the location of the dimension lines, as illustrated in Figure 30-2. The control handles that
appear depend on the dimension shape you choose. As an example, you can add dimensions from a vertical baseline by following these steps:

1. Drag the Vertical Baseline shape onto the page near the bottom of the part you want to dimension. Drag the green end points to both position the ends of the horizontal reference lines and define the distance for the first dimension.
2. To position the text and vertical dimension line for the first dimension, drag the yellow control handle on the first dimension line.
3. Drag the yellow control handle between the green selection handles up and to the left to add another vertical dimension line.
4. After you have added the dimensions you want, you can drag the control handles at the top of each dimension up or down to change the height of the dimension. When you drag these yellow control handles to the left or right, Visio repositions the horizontal reference line.
5. To change the spacing between the vertical dimension lines, drag the yellow control handle at the bottom of the Vertical Baseline shape.

FIGURE 30-2
Drag control handles on Dimension shapes to modify the distance you want to measure and the position of the dimension lines.
Datum points and datum frames show origins and geometric characteristics. Datum points delinate positions that you can use to align shapes on different pages or drawings. To add these symbols, use one of the following methods:

- **Datum shapes** — Drag a Datum shape, such as Datum Symbol or Datum (New), from the Geometric Dimensioning and Tolerancing stencil onto the drawing page and, while the shape is selected, type the text you want in the symbol. Press Esc to complete your text entry.

- **Datum Frame** — Drag a Datum Frame shape, such as 1 Datum Frame or 2 Datum Frame, onto the drawing page, and then double-click it to open the group window. To denote geometric characteristics, drag shapes, such as Cylindricity, into the box on the left end of the Datum Frame shape. To add text to the other boxes in the shape, double-click the box and type the text you want. When you have finished editing the Datum Frame shape, click the Close button for the group window to return to the drawing window.

### Constructing Fluid Power Diagrams

The Visio Fluid Power template helps you draw the pipes and equipment that make up fluid power systems. To create a fluid power drawing, choose File ➪ New ➪ Engineering ➪ Fluid Power. Visio creates a new letter-size drawing in landscape orientation with no scale and opens the following stencils:

- **Engineering** ➪ **Mechanical Engineering** stencil category:
  - **Fluid Power-Equipment** — Pumps, compressors, gauges, meters, and other types of equipment
  - **Fluid Power-Valve Assembly** — Shapes that represent valves and control equipment
  - **Fluid Power-Valves** — Different types of valves

- **Visio Extras** stencil category:
  - **Annotations** — Annotation shapes for callouts, text blocks, north arrows, reference and section indicators, and scale symbols
  - **Connectors** — Different types of generic connectors

Putting together fluid power diagrams requires nothing more than basic Visio techniques and a background in the design of fluid power systems. Use one or more of the following methods to construct a fluid power diagram:

- **Add shapes to drawings** — Drag shapes from Fluid Power stencils onto the drawing page.

- **Reconfigure shapes** — Right-click a shape and choose a command from the shortcut menu. For example, you can configure the Pump/motor (Simple) shape to be hydraulic or pneumatic, bidirectional or unidirectional, variable, or compensated. You can also configure the Pump/motor (Simple) shape to represent a pump, a motor, or a combination of the two.
Part V Using Visio for Architecture and Engineering

**NOTE** Most but not all shapes on Fluid Power stencils include configuration commands on their shortcut menus.

- **Annotate shapes** — Add text by selecting a shape and typing the text you want. After you add text, most shapes include a control handle you can drag to reposition the text if it overlaps graphics on the drawing.
- **Connect equipment** — Use the Connector tool to connect equipment, as described in Chapter 5.

**NOTE** Some shapes on Fluid Power stencils include control handles that you can use to connect them to other shapes. To find out what a control handle does, view a screen tip by positioning the pointer over the control handle.

### Working with Electrical Engineering Drawings

To create an electrical engineering drawing, choose File ➪ New ➪ Engineering and then choose the template for the type of drawing you want. Visio creates a new letter-size drawing in portrait orientation and no scale. As with mechanical engineering drawings, basic Visio techniques are the tools available for constructing electrical engineering drawings.

**CAUTION** Electrical Engineering shapes include connection points that are not interchangeable, such as the positive or negative terminals on a battery. When you construct electrical engineering diagrams, take care to glue to specific connection points, rather than use shape-to-shape glue. When you glue connectors to Electrical Engineering shapes, make sure that Visio highlights only the connection points in red, not the entire shape.

### Building Process Engineering Models

With the Visio Process Engineering template, it’s easy to draw piping and instrumentation diagrams (P&IDs) and process flow diagrams (PFDs). You can drag shapes from Process Engineering Equipment stencils onto your drawing page, connect them with Pipeline shapes, and then add shapes to represent components, such as valves. Process engineering models use components to represent physical objects, such as pipelines or pieces of equipment. In addition to the graphical view of your process engineering diagram, you can use the Component Explorer and Connectivity Explorer windows to examine the hierarchy of components and connections.

Shape data holds information about process engineering components that you can use to produce reports or equipment lists. In addition, tags identify and track the components on your drawings. By default, when you drag components onto the drawing page, Visio adds tags and displays the tag text in component text blocks. You can choose to hide or show tag information to improve the readability of a drawing. Although Visio provides predefined tag formats, you can also create your own. If you construct different views that contain the same component, such as an overall plan and a detail, you can assign the same tag to multiple shapes, so you can accurately track components.
Viewing Process Engineering Diagrams in Different Ways

In addition to Visio drawing pages, the Component Explorer and Connectivity Explorer windows show components and connections in a process engineering model in outline form. The Shape Data window comes in handy when you want to examine data associated with components. The Processing Engineering templates provide the following windows for viewing and working on your process engineering models and drawings:

- **Drawing window** — Turn to this window when you want to see how process equipment is connected. Process engineering diagrams can span multiple pages or include both overview and detailed portions of a model. When you select a shape in the drawing window, Visio highlights the corresponding component in the Component Explorer window.

- **Component Explorer window** — This window categorizes the components in a model into groups, such as Equipment, Pipelines, Valve, or Instrument. The outline shows the tag number for each component as well as each shape that represents the component, for example, when a component appears on more than one page of the diagram. Component tag numbers appear in the outline.

- **Connectivity Explorer window** — This window focuses on the pipelines that connect components in your model. Pipelines appear at the top level of the hierarchy, identified by their tag numbers. Underneath each pipeline, the components connected to the pipeline are listed by tag number.

- **Shape Data window** — Whether you select a shape in one of the Explorer windows or on the drawing page, the Shape Data window is the easiest way to browse values from shape to shape. Select a shape on the drawing page or in the Component Explorer or Connectivity Explorer window and its shape data appears in the Shape Data window. Process Engineering shapes come with several properties predefined. For example, Pipeline shapes include properties for line size, material, design pressure, design temperature, and more.

Open and close Explorer windows or switch between Explorers depending on what you want to see. To open an Explorer window, choose Process Engineering ➤ Component Explorer or Process Engineering ➤ Connectivity Explorer.

**TIP**
When both Explorer windows are open, you can switch between Explorers by selecting the Components or Connectivity tab at the bottom of the window.

The outline format of the Explorer windows makes it easy to see your entire model even if it spans several drawing pages. The Expand and Collapse icons filter the components you see, as shown in Figure 30-3. What’s more, you can perform any tasks in the Explorer windows that you can do on a drawing page — create new components, rearrange them, and rename them. And the Explorer windows are particularly helpful when you want to find a component on a complex drawing — right-click a component in an Explorer window and, from the shortcut menu, choose Select Shapes. Visio zooms into the shape on the drawing.
FIGURE 30-3

The Explorer windows not only perform all the tasks you use with shapes on drawing pages. They also make it easy to find shapes on large and complex drawings.

Work with components using any of the methods described in Table 30-1.

TABLE 30-1

<table>
<thead>
<tr>
<th>Task</th>
<th>Description</th>
<th>Explorer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand or collapse</td>
<td>Click the plus icon to expand the outline to show the next lower level in the hierarchy. Click the minus icon to hide the lower level.</td>
<td>Both</td>
</tr>
<tr>
<td>hierarchy levels</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select components</td>
<td>Double-click a component or right-click a component and then, from the shortcut menu, choose Select Shapes. Visio selects the shape that represents the component on the drawing page.</td>
<td>Both</td>
</tr>
<tr>
<td>Rename components</td>
<td>Right-click a component in an Explorer window and, from the shortcut menu, choose Rename. Type the new name and press Esc when you're done. Visio renames the component in the Explorer windows and the drawing.</td>
<td>Both</td>
</tr>
<tr>
<td>Create components</td>
<td>Create a new component by right-clicking the category to which you want to add a component and then, from the shortcut menu, choose New Component.</td>
<td>Component Explorer only</td>
</tr>
<tr>
<td>Associate shapes</td>
<td>To change the component to which a shape belongs, in the Components Explorer window, drag a shape from one component to another component in the same category.</td>
<td>Component Explorer only</td>
</tr>
<tr>
<td>with other components</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Creating P&ID and PFD Drawings

Creating process engineering drawings isn’t much different than creating any other type of engineering drawing, although Visio provides a few additional tools to simplify some tasks, such as adding valves to pipelines. The steps in this section provide an overview of the basic sequence for creating a process engineering drawing. Following sections provide more detailed instructions about building specific portions of a process engineering drawing.

To create a process engineering drawing, choose File ➤ New ➤ Engineering and then choose the template for the type of drawing you want. Visio creates a new ANSI B-size (17 inches by 11 inches) drawing in landscape orientation and with no scale. In fact, whether you want to create a P&ID or a PFD, you can choose either template, because they both open the same stencils from the Process Engineering category:

- Equipment-General
- Equipment-Heat Exchangers
- Equipment-Pumps

Updating Visio 2000 Process Engineering Projects

Visio process engineering drawings changed drastically between Visio 2000 and Visio 2002. Projects contained all the drawings and documents for a model, including PFDs, P&IDs, and other files. Projects could contain multiple drawings, each in its own Visio drawing file, so the Project Explorer helped you navigate a Visio 2000 model.

To take advantage of all the features in the current Visio Process Engineering solution, you must update models built in Visio 2000. To do this, migrate a Visio 2000 Process Engineering project to Visio 2002 and then open it in Visio Professional 2007. The migration process converts each drawing in a Visio 2000 project to a separate Visio 2002 process engineering drawing, but doesn’t affect the Visio 2000 files in any way. In moving to Visio 2007, you can include several process engineering drawings in the same Visio drawing file by adding each drawing as a separate page.

To migrate a Visio 2000 Process Engineering project to Visio 2007, follow these steps:

1. To save the migrated files in a new folder, create a destination folder using Windows Explorer.
2. Open the Visio 2000 Process Engineering project (.vsd) in Visio 2002. When Visio prompts you, click Enable Macros to begin the migration. When Visio prompts you to migrate all drawings, click Yes to convert all the drawings in the Visio 2000 project to Visio 2002 drawings.
3. In the Browse for Folder dialog box, select the destination folder you created in step 1 and then select a file name. Visio begins to migrate the files into the new format. The migration process might take some time, particularly if you are migrating a large Visio 2000 project. To avoid tying up your computer, you can start the migration and let it run on its own.
4. After the migration is complete, click OK. Visio presents a summary of the names and paths of the migrated files. Review the summary and then open the migrated files in Visio 2007.
To assemble a process engineering drawing, follow these basic steps:

1. Add major equipment first by dragging shapes from the Equipment-Vessels, Equipment-Pumps, Equipment-Heat Exchangers, and Equipment-General stencils onto your drawing. As you drop them onto the page, Visio adds tags that identify each piece of equipment as a component.

2. Connect the equipment with Pipeline shapes. The easiest way to connect Equipment shapes using Pipeline shapes is to click the Connector tool on the Standard toolbar, select the Pipeline master you want to use in the Pipelines stencil, and then, on the drawing page, drag the mouse pointer from one equipment shape to another.

   TIP
   To change to a different type of pipeline, select another Pipeline master in the Pipelines stencil and then continue to drag between Equipment shapes on the drawing page.

   NOTE
   To modify the direction of a pipeline or the type of pipeline, change the line style of the Pipeline shape, as described in the next section.

3. Insert valves into pipelines by dragging Valve shapes from the Valves and Fittings stencil onto Pipeline shapes on the drawing page. When a red square appears on the Pipeline shape and the Valve shape rotates to the orientation of the Pipeline shape, release the mouse button to glue the two together. Visio automatically splits the Pipeline shape into two pieces, both of which are glued to the Valve shape.

4. Attach monitoring instruments to equipment and pipelines by dragging Instrument shapes from the Instruments stencil onto the drawing page near the shapes for the equipment that the instruments monitor. If the Instrument shape includes a control handle, you can drag it to glue the Instrument shape to the shape for the component it monitors.

5. Annotate the drawing by dragging shapes from the Process Annotations stencil.

6. Add data to components. Choose View ➤ Shape Data Window. Select a shape, click a shape data field, and then type or select a value.

**Building Pipelines**

Pipelines are components that connect equipment, such as vessels or centrifuges. However, when you connect Pipeline shapes to one another or add shapes for other equipment components to them, Visio splits the Pipeline shapes into separate shapes. Although a pipeline might comprise several separate shapes on the drawing page, Visio keeps them all associated with the same component and sharing the same tag and shape data values.
Specifying How Pipeline Shapes Behave
To control how pipelines behave when you add valves or connect other pipelines, choose Process Engineering ➤ Diagram Options and then specify the following options:

- To split Pipeline shapes when you drop Valve and Fitting shapes onto them, select the Split Pipelines Around Components check box.
- To split Pipeline shapes when you connect other Pipeline shapes to them, select the Split Pipelines When Branches Are Created check box. In the Use This Shape At Pipeline Branches drop-down list, you can choose the shape that Visio inserts to designate branches, such as Junction.

If Pipeline shapes don’t split despite turning on the above settings, be sure that you are gluing to shape geometry. Choose Tools ➤ Snap & Glue and check the Shape Geometry check box under the Glue To heading.

- To repair Pipeline shapes when you delete components or other Pipeline shapes, select the Repair Split Pipelines check box.
- To instruct Visio to automatically number the components you add, select the Number Components When They Are Added To The Drawing check box.

Adding Components to Pipelines
When you drop a Valve shape onto a Pipeline shape, Visio splits the Pipeline shape into two pieces, with the ends of the two segments glued to the component you inserted, as shown in Figure 30-4. The two shapes still belong to the same component and share the same tag and properties as the original Pipeline shape.

When you connect one pipeline to another, the original Pipeline shape also splits into two pieces. Visio adds a Junction shape at the point where the three Pipeline shapes intersect (the added pipeline and the pipeline that’s been split in two). Although you don’t see Junction shapes on the drawing page, they do appear in the Connectivity Explorer window.

If you want to display junction shapes — for example, to validate your drawing — choose Process Engineering ➤ Diagram Options, check the Split Pipelines When Branches Are Created check box, and then select Junction in the drop-down list.

To add a valve or fitting to a pipeline, follow these steps:

1. Drag a Valve or Fitting shape from the Valves and Fittings stencil and position it on top of a Pipeline shape.
2. When Visio displays a red square and rotates the valve or fitting to the pipeline, release the mouse button. Visio splits the Pipeline shape in two, gluing the two Pipeline shapes to either end of the valve or fitting shape.
When pipelines split, the shapes still belong to the same component. However, if you delete a component between two different pipeline components, the pipelines remain separate components. If pipelines that belong to the same component don’t repair themselves when you delete a component, choose Process Engineering ➤ Diagram Options and check the Repair Split Pipelines check box.

**Continuing Pipelines on Other Pages**

In some circumstances, you might want to continue the same pipeline on different pages, for example, a long pipeline that connects hundreds of equipment components. The Process Annotations stencil includes shapes for indicating that a pipeline continues on another page. Despite their names, these shapes are identical to Off-Page Reference shapes. To learn how to use these shapes to continue pipelines, follow the instructions for Off-Page Reference shapes in Chapter 6.

**Working with Components**

In a process engineering model, components represent individual real-world objects such as valves, pumps, or pipelines. In Visio process engineering drawings, components are made up of one or more Visio shapes. For example, a main pipeline with several intersecting branches requires a separate Visio shape for each segment, but to you, it’s still one component. Each component includes properties, such as pressure, temperature, or material, which apply to all the shapes in it.
You can categorize components in a process engineering model so that it’s easier to track and report on different types of components. Visio includes several categories corresponding to the Process Engineering stencils: Equipment, Instrument, Pipelines, and Valve. You can create your own categories as well.

Only shapes from the Process Engineering stencils appear automatically in the Component and Connectivity Explorer windows. If you add shapes from other stencils or draw your own, they won’t appear as components. However, you can convert these shapes so that they will work with Visio Process Engineering features by following the steps outlined in the section “Converting Shapes and Symbols into Components.”

**Associating Shapes with Components**

Visio automatically creates components when you add shapes from Process Engineering stencils to drawings. Each shape you place on the drawing page receives a tag number that identifies the component to which the shape belongs. However, you can associate more than one shape with the same component or transfer ownership of a shape from one component to another.

Use one of the following methods to associate a shape with a component:

- In the Component Explorer window, drag an entry from one component to another component in the same category.
- On the drawing page, select a shape and type the tag for the component to which you want the shape to belong. Visio doesn’t give you any indication that typing will change the component tag, but as soon as you begin typing, the shape text box appears with the current tag number. When you click away from the text box, you’ll see the item switch to its new component in the Component Explorer window.

If you want to remove a component association completely, you must delete the shape on the drawing page.

**Working with Component Data**

To accurately model and engineer processes, your drawings must include information about the components in the process, such as the operating temperature range for a piece of equipment or the design pressure of a pipeline. Visio uses shape data to store process engineering data as well as to configure shapes — for example, displaying different versions of the shape depending on the type of instrument you choose.

Process Engineering shapes come with several shape data fields by default, as shown in Table 30-2. Visio uses shape data sets to associate groups of fields with each category of component. You can use these fields and shape data sets or modify them to suit your organization’s needs. Although you can add data to components individually in the Shape Data window, Visio’s Database wizards can import and link data directly from engineering databases.

To learn how to create your own shape data fields and shape data sets and apply them to Visio shapes, see Chapter 33.
To learn how to add values to shape data fields as well as how to import data from databases or link Visio shapes to database records, see Chapter 10.

**TABLE 30-2**

Default Custom Properties for Component Categories

<table>
<thead>
<tr>
<th>Equipment</th>
<th>Instruments</th>
<th>Pipelines</th>
<th>Valves and Fittings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Description</td>
<td>Description</td>
<td>Description</td>
</tr>
<tr>
<td>Material</td>
<td>Connection Size</td>
<td>Line Size</td>
<td>Line Size</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Service</td>
<td>Schedule</td>
<td>Valve Class</td>
</tr>
<tr>
<td>Model</td>
<td>Manufacturer</td>
<td>Material</td>
<td>Manufacturer</td>
</tr>
<tr>
<td>Model</td>
<td>Model</td>
<td>Design Pressure</td>
<td>Model</td>
</tr>
<tr>
<td>Instrument Type</td>
<td>Design Temperature</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Local/remote</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Displaying Component Data**

Visio displays the component tag in the text block of each Process Engineering shape by default, but you can show or hide component tags depending on whether you want to unclutter a busy diagram or make information readily available. To hide or show the tag for a shape, right-click the shape on the drawing page and, from the shortcut menu, choose Hide Tag or Show Tag (the command toggles between the two).

In addition, you can display other component data on the drawing page. For example, Callout shapes from the Process Annotations stencil can show key design attributes on the drawing, such as temperature or pressure.

To display component data using Callout shapes, follow these steps:

1. Drag one of the Callout shapes from the Process Annotations stencil onto the drawing page near the shape whose properties you want to display.
2. Drag the control handle from the Callout shape to any point on the shape that you want to annotate.
3. In the Configure Callout dialog box, select the check boxes for the shape data fields you want to display in the Callout shape. With the Callout shape linked to the shape data, changes to those fields appear in the Callout shape automatically. If you select more than one field, be sure to specify a separator, so you can distinguish individual values in the Callout shape.
If you want to change the order in which fields appear in the Callout shape, select a field and then click Move Up or Move Down to reposition it in the order.

4. To show the property name in addition to the value, check the Show Property Name check box.

5. Click OK. The properties appear in the Callout shape.

To change the properties that appear or change whether the property name is shown after you add the Callout shape to the drawing page, right-click the Callout shape and, from the shortcut menu, choose Configure Callout. Choose Show Leader to draw a leader from the Callout shape to its associated shape.

Tagging and Numbering Components
Visio identifies the components in your process engineering model with a tag. In Process Engineering shapes, the tag appears in the shape's text block. By default, Visio formats tags as <tag name>-<tag counter>, for example, P-10. By default, the tag name is the first letter of the component category and the tag counter is a number that increments by one every time you add a component from that category to the drawing. If you want to number components in a specific way, you can define your own custom tag format.

If you don't want Visio to automatically number components as you add them, choose Process Engineering ➤ Diagram Options and uncheck the Number Components When They Are Added to the Drawing check box.

Applying Tag Formats to Shapes
The easiest way to change the tag format for all instances of a shape is to change the tag format for a master on a stencil. To use a different tag format for shapes already on a drawing, follow these steps:

1. Select the shape or shapes you want to change on the drawing page and then choose Process Engineering ➤ Apply Tag Format.

2. In the Apply Tag Format dialog box, in the Tag Format drop-down list, select the tag format you want, select the Apply To Shapes Selected In Drawing option, and click OK.

To change the tag format for masters in a stencil, follow these steps:


2. In the Apply Tag Format dialog box, select the tag format you want in the Tag Format drop-down list.

3. Select the Apply To Shapes In A Stencil option and then click Choose Shapes.

4. In the Choose Shapes dialog box, the Document drop-down list includes all the open stencils. Select the stencil you want to modify.

If you want to choose masters on the Document stencil, select the drawing name in the Document drop-down list.
5. Select the check boxes for the masters whose tag formats you want to change and click OK. In the Apply Tag Format dialog box, click OK to apply the new tag format to the selected masters.

6. Right-click the stencil title bar in the Shapes window and, from the shortcut menu, choose Save As to save the modified stencil as a custom stencil.

Defining Tag Formats

Although Visio includes a default tag format for each category of components in the Process Engineering templates, you can modify these formats to fit your organization's standards or create formats of your own. Tag formats can include text, punctuation, the values of shape data, and numeric sequences, and can span more than one line.

To create a new tag format, follow these steps:

2. Type the name for the new tag format in the Name box.
3. Use one of the following options to specify the basis for the new format:
   - **Create a New Format** — Choose this option to create a brand-new format based on the default tag format, `<tag format name>-[Counter]`.
   - **Create from an Existing Format** — Choose this option to use an existing format as the basis for the new tag format. Select the drawing or stencil that contains the format you want to use in the Document drop-down list. Then, from the Format drop-down list, select the tag format you want to use.
4. Click OK. Visio adds the new name to the Tag Format list.

To edit a format, follow these steps:

1. In the Edit Tag Formats dialog box, select the tag format you want to modify and click Modify. Visio opens the Tag Format Properties dialog box and selects the text in the Tag Expression box.

   **NOTE** The Sample Tag Value box shows a preview of the current tag expression.

   2. To insert text in the tag expression, position the insertion point in the tag expression and type the text you want.

   **TIP** You can add punctuation marks, such as hyphens, to the tag expression text to separate fields.

   3. To replace text in the tag expression, select the text and type the new text you want.

   4. To create a multi-line tag, position the insertion point where you want to start a new line in the tag expression and press Enter.
5. To add a shape data field to the tag expression, position the insertion point where you want to insert the property, select a field in the Available Shape Data Properties list, and then click Insert Property.

6. To insert a sequential counter to the tag expression, position the insertion point where you want to insert the counter and then click Insert Counter.

**TIP** You can specify the number of digits that the counter occupies by selecting an entry in the Format drop-down list. Visio adds leading zeroes to the counter. For values larger than the number of digits specified, Visio simply adds more digits to the counter.

7. When you have completed the tag expression, click OK. The tag expression appears in the Expression column of the Edit Tag Formats dialog box.

**NOTE** You can also rename or delete tag formats in the Edit Tag Formats dialog box by clicking Rename or Delete.

### Renumbering Components

As you add components to your model, Visio numbers tags using a numeric sequence. For example, the tag for the first piece of equipment you add is E-1, followed by E-2, and so on. However, as you work on a model, you might want to clean up the tag sequence. For example, if you delete components or reassign shapes from one component to another, you can end up with sequence numbers that are no longer used. You can renumber components to reuse those numbers, specifying the starting value you want to use and the increment between each tag.

To renumber the components in a model, follow these steps:

2. To specify which components you want to renumber, click one of the following options:
   - **Document** — Renumbers all the components in the current drawing file
   - **Page** — Renumbers all the components on the current drawing page
   - **Selection** — Renumbers the selected components
3. Clear the check boxes for any tag format you don’t want to renumber. By default, all the tag formats are checked.
4. To specify how to renumber components that use a tag format, select a tag format in the Include Tag Formats list. Type the starting value in the Starting Value box and type the increment between numbers in the Interval box. Repeat these steps for each tag format.
5. Click OK to renumber the components.

**NOTE** After Visio renumbers the components, the tags for new components begin where the last renumbered components left off. In addition, new tags use the settings from the renumbering you applied. For example, if you renumber pipelines starting at 100 using an interval of 2 and the pipelines in the model are tagged from 100 to 128, the next pipeline you add will start at 130.
Generating Component Lists and Bills of Material

You can generate reports about components in your model from the values in shape data. Visio includes a predefined report for each category of components, which lists specific information about each component. You can use these reports as provided or use Visio’s report features to define your own reports. Even if you don’t add values to shape data, you can still run these built-in reports to see a list of components by tag number, because Visio adds tag numbers automatically.

Visio provides the following predefined reports:

- **Equipment List** — Includes tag number, description, manufacturer, material, and model
- **Instrument List** — Includes tag number, description, connection size, service, manufacturer, and model
- **Pipeline List** — Includes tag number, description, line size, schedule, design pressure, and design temperature
- **Valve List** — Includes tag number, description, line size, valve class, manufacturer, and model
- **Inventory** — Shows the number of shapes on the page grouped by shape name

To run one of these reports, choose Data ➤ Reports, select it in the Report list, and then click Run.

To learn more about creating, modifying, and running reports, see Chapter 10.

Converting Shapes and Symbols into Components

In order to work with Visio Process Engineering features, shapes must belong to a component category and have a tag format assigned to them. Without these, you won’t see the shapes in the Component Explorer or Connectivity window and they won’t function as other Process Engineering shapes do. However, you can convert shapes or objects from other sources into Process Engineering shapes using the Shape Conversion command. You can convert the following elements:

- Shapes you draw with Visio drawing tools
- Existing shapes on a drawing page
- Shapes from stencils other than the Process Engineering stencils
- Symbols created in AutoCAD

Process Engineering shapes can lose their attributes if you perform some actions — for example, ungrouping a grouped Process Engineering shape or applying Shape Operation commands to them. When this happens, you can use the Shape Conversion command to reassign a category and tag format.
To transform shapes or symbols into Process Engineering shapes, follow these steps:

1. If you want to convert shapes on the drawing page, select the shapes you want to convert.

2. Choose Process Engineering ➪ Shape Conversion. Then, under the Source heading, choose one of the following options:
   - **Selected Shapes** — Converts the shapes you selected on the drawing page.
   - **Shapes in a Visio Stencil** — Converts masters on a Visio stencil. Click Choose Shapes, select the stencil in the Document list, check the check boxes for the masters you want to convert, and click OK.
   - **Symbols in a CAD File** — Converts symbols in a CAD file. Click Browse and then locate and select the CAD file containing the symbols you want to convert. To set the drawing scale in Visio, enter a positive value for the number of Visio measurement units that equals one CAD unit and select the units you want to use in the Units drop-down list.

3. Select or type the name of a category in the Category box to assign it to the converted shapes.

   If you type a category name that doesn’t exist, Visio creates a new category for you.

4. In the Tag Format list, select a tag format to assign it to the converted shapes.

   To apply shape data sets to the converted shapes, see Chapter 33.

5. Click OK to convert the shapes. If you converted CAD symbols, Visio creates a new stencil that contains the shapes you converted. To save the stencil, right-click the stencil title bar and choose Save from the shortcut menu.

**Summary**

Visio provides templates for mechanical, electrical, and process engineering drawings. You can use basic Visio techniques such as drag and drop to perform much of the work for creating drawings. Visio uses shape data not only to add engineering information to shapes but also to configure shapes to show different varieties of equipment.

The Process Engineering templates help you build a model and a drawing. Visio uses components with identifying tags to track and report on the objects in a process engineering model. The Component and Connectivity Explorer windows present your model as an outline. You can create, delete, rename, and move components around on the drawing page or in these windows.